cpio: fix boot with dynamic /dev
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 6 Sep 2011 21:16:08 +0000 (23:16 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 27 Sep 2011 20:36:26 +0000 (22:36 +0200)
Devtmpfs doesn't get automounted by the kernel when an initramfs is used.
Since cpio archives are used almost exclusively as an initramfs, the same
fix should be applied to it as for the initramfs.

Cfr. commit 424888e47431db738f5f9b3c6392435bfce7a842 and
10a130f91e5b947e2d2558443ff09b1686eac273.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/cpio/cpio.mk
fs/cpio/init [new file with mode: 0755]

index ab7d546185bae66de0cc070d56fb0b5c4026d4f4..aa20b41074101995fb0c0d6f8aee6316a8c225f9 100644 (file)
@@ -4,15 +4,29 @@
 #
 #############################################################
 
-define ROOTFS_CPIO_INIT_SYMLINK
-       rm -f $(TARGET_DIR)/init
-       ln -s sbin/init $(TARGET_DIR)/init
+ifeq ($(BR2_ROOTFS_DEVICE_CREATION_STATIC),y)
+
+define ROOTFS_CPIO_ADD_INIT
+        if [ ! -e $(TARGET_DIR)/init ]; then \
+                ln -sf sbin/init $(TARGET_DIR)/init; \
+        fi
+endef
+
+else
+# devtmpfs does not get automounted when initramfs is used.
+# Add a pre-init script to mount it before running init
+define ROOTFS_CPIO_ADD_INIT
+        if [ ! -e $(TARGET_DIR)/init ]; then \
+                $(INSTALL) -m 0755 fs/cpio/init $(TARGET_DIR)/init; \
+        fi
 endef
 
-ROOTFS_CPIO_PRE_GEN_HOOKS += ROOTFS_CPIO_INIT_SYMLINK
+endif # BR2_ROOTFS_DEVICE_CREATION_STATIC
+
+ROOTFS_CPIO_PRE_GEN_HOOKS += ROOTFS_CPIO_ADD_INIT
 
 define ROOTFS_CPIO_CMD
        cd $(TARGET_DIR) && find . | cpio --quiet -o -H newc > $$@
 endef
 
-$(eval $(call ROOTFS_TARGET,cpio))
\ No newline at end of file
+$(eval $(call ROOTFS_TARGET,cpio))
diff --git a/fs/cpio/init b/fs/cpio/init
new file mode 100755 (executable)
index 0000000..a275482
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh
+# devtmpfs does not get automounted for initramfs
+/bin/mount -t devtmpfs devtmpfs /dev
+exec 0</dev/console
+exec 1>/dev/console
+exec 2>/dev/console
+exec /sbin/init $*