package/pkg-meson.mk: fix cross-compilation.conf
authorGleb Mazovetskiy <glex.spb@gmail.com>
Wed, 11 Mar 2020 19:19:39 +0000 (19:19 +0000)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 11 Mar 2020 21:25:41 +0000 (22:25 +0100)
$$(STAGING_DIR) -> $(STAGING_DIR) in PKG_MESON_INSTALL_CROSS_CONF.

$$ resulted in `$(STAGING_DIR)` in the file instead of the expanded
value.

Note that this change only affects the etc config at:
host/etc/meson/cross-compilation.conf

Per-package cross-compilation.conf files are already correct.

Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Gleb Mazovetskiy <glex.spb@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-meson.mk

index 642b7159385bb7807131fe48872ed7daa2b29daf..416129f6fed0d73ce242d78d0141614622dee0dd 100644 (file)
@@ -193,7 +193,7 @@ define PKG_MESON_INSTALL_CROSS_CONF
            -e 's%@TARGET_LDFLAGS@%$(call make-comma-list,$(TARGET_LDFLAGS))@PKG_TARGET_CFLAGS@%g' \
            -e 's%@TARGET_CXXFLAGS@%$(call make-comma-list,$(TARGET_CXXFLAGS))@PKG_TARGET_CFLAGS@%g' \
            -e 's%@HOST_DIR@%$(HOST_DIR)%g' \
-           -e 's%@STAGING_DIR@%$$(STAGING_DIR)%g' \
+           -e 's%@STAGING_DIR@%$(STAGING_DIR)%g' \
            $(HOST_MESON_PKGDIR)/cross-compilation.conf.in \
            > $(HOST_DIR)/etc/meson/cross-compilation.conf.in
        sed -e 's%@PKG_TARGET_CFLAGS@%%g' \