package/zsh: add optional support for libcap
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 09:50:11 +0000 (10:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 11:42:43 +0000 (12:42 +0100)
When libcap was compiled before, zsh will use it as optional dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/bin/zsh | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libgdbm.so.4]
 0x0000000000000001 (NEEDED)             Shared library: [libcap.so.2]
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/zsh/zsh.mk

index c3af03410183862a599da25746382788d32d127a..9f4a5827b71ce43095e43781ea7ca35e9bbdf692 100644 (file)
@@ -19,6 +19,13 @@ else
 ZSH_CONF_OPTS += --disable-gdbm
 endif
 
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+ZSH_CONF_OPTS += --enable-cap
+ZSH_DEPENDENCIES += libcap
+else
+ZSH_CONF_OPTS += --disable-cap
+endif
+
 # Remove versioned zsh-x.y.z binary taking up space
 define ZSH_TARGET_INSTALL_FIXUPS
        rm -f $(TARGET_DIR)/bin/zsh-$(ZSH_VERSION)