package/hplip: fixup configure.in script for proper autoreconf
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 Jan 2016 23:04:51 +0000 (00:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 Jan 2016 23:05:50 +0000 (00:05 +0100)
This commit adds a minor patch to hplip's configure.in script, which
avoids the need to create the AUTOHRS, ChangeLog, NEWS and README
files before autoreconfiguring, and silences a huge number of warnings
telling to enable the subdir-objects automake option.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/hplip/0002-configure.in-fix-AM_INIT_AUTOMAKE-call.patch [new file with mode: 0644]
package/hplip/hplip.mk

diff --git a/package/hplip/0002-configure.in-fix-AM_INIT_AUTOMAKE-call.patch b/package/hplip/0002-configure.in-fix-AM_INIT_AUTOMAKE-call.patch
new file mode 100644 (file)
index 0000000..7c7538d
--- /dev/null
@@ -0,0 +1,35 @@
+From a2de7e834417de68db10dc6f09d5810b06e6cbc8 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Thu, 21 Jan 2016 23:54:50 +0100
+Subject: [PATCH] configure.in: fix AM_INIT_AUTOMAKE call
+
+Uncomment the appropriate call to AM_INIT_AUTOMAKE so that the
+"foreign" option is passed, which avoids the need for creating various
+unneeded files when autoreconfiguring.
+
+Add the subdir-objects options since the main Makefile.am references
+files in subdirectories. This allows to silence a huge amount of
+warning when autoreconfiguring.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.in | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 8b06428..680cad5 100755
+--- a/configure.in
++++ b/configure.in
+@@ -27,8 +27,7 @@
+ #AC_PREREQ(2.59)
+ AC_INIT([HP Linux Imaging and Printing], [3.15.11], [3.15.11], [hplip])
+-#AM_INIT_AUTOMAKE([1.9 foreign])
+-AM_INIT_AUTOMAKE
++AM_INIT_AUTOMAKE([1.9 foreign subdir-objects])
+ AC_DISABLE_STATIC
+ # Checks for programs.
+-- 
+2.6.4
+
index 62cf9c0363ad4cbf488cbbb85b86b732ff8515bb..b1e8cb55d25a05127d650089c07e5ac2e6a39dd4 100644 (file)
@@ -40,12 +40,4 @@ define HPLIP_POST_INSTALL_TARGET_FIXUP
 endef
 HPLIP_POST_INSTALL_TARGET_HOOKS += HPLIP_POST_INSTALL_TARGET_FIXUP
 
-define HPLIP_PRE_CONFIGURE_FIXUP
-       touch $(@D)/AUTHORS
-       touch $(@D)/ChangeLog
-       touch $(@D)/NEWS
-       touch $(@D)/README
-endef
-HPLIP_PRE_CONFIGURE_HOOKS += HPLIP_PRE_CONFIGURE_FIXUP
-
 $(eval $(autotools-package))