odroid-scripts: init display as early as possible
authorDagg Stompler <daggs@gmx.com>
Fri, 25 Nov 2016 07:48:46 +0000 (09:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Nov 2016 21:02:02 +0000 (22:02 +0100)
this commit will init the display as early as possible so the user can
see on screen the boot process.
the displey init will be called after the logging init to provide some
logging of the init.

Signed-off-by: Dagg Stompler <daggs@gmx.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/odroid-scripts/S02odroidc2_fb [new file with mode: 0644]
package/odroid-scripts/S50odroidc2_fb [deleted file]
package/odroid-scripts/odroid-scripts.mk

diff --git a/package/odroid-scripts/S02odroidc2_fb b/package/odroid-scripts/S02odroidc2_fb
new file mode 100644 (file)
index 0000000..2aae59d
--- /dev/null
@@ -0,0 +1,20 @@
+#!/bin/sh
+#
+# Set up frame buffer
+#
+
+case "$1" in
+    start)
+        echo "Setting up display..."
+        /usr/sbin/odroidc2_init_fb.sh
+        ;;
+    stop)
+        ;;
+    restart|reload)
+        ;;
+    *)
+        echo "Usage: $0 {start|stop|restart}"
+        exit 1
+esac
+
+exit $?
diff --git a/package/odroid-scripts/S50odroidc2_fb b/package/odroid-scripts/S50odroidc2_fb
deleted file mode 100644 (file)
index 2aae59d..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-#
-# Set up frame buffer
-#
-
-case "$1" in
-    start)
-        echo "Setting up display..."
-        /usr/sbin/odroidc2_init_fb.sh
-        ;;
-    stop)
-        ;;
-    restart|reload)
-        ;;
-    *)
-        echo "Usage: $0 {start|stop|restart}"
-        exit 1
-esac
-
-exit $?
index 858ec37fe88af1c3f77f43ff64d1a0232eff5573..72e7b9588007e5e2cb0e540179c1a6f498212bcb 100644 (file)
@@ -29,8 +29,8 @@ define ODROID_SCRIPTS_INSTALL_INIT_SYSTEMD
 endef
 
 define ODROID_SCRIPTS_INSTALL_INIT_SYSV
-       $(INSTALL) -D -m 0755 package/odroid-scripts/S50odroidc2_fb \
-               $(TARGET_DIR)/etc/init.d/S50odroidc2_fb
+       $(INSTALL) -D -m 0755 package/odroid-scripts/S02odroidc2_fb \
+               $(TARGET_DIR)/etc/init.d/S02odroidc2_fb
 endef
 
 $(eval $(generic-package))