package/gobject-introspection: export variables in g-ir-scanner
authorAdam Duskett <Aduskett@gmail.com>
Sun, 15 Mar 2020 15:33:20 +0000 (16:33 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 15 Mar 2020 16:37:31 +0000 (17:37 +0100)
When building .gir .typelib files, the g-ir-scanner wrapper calls the host
g-ir-scanner. g-ir-scanner calls ccompiler.py, which searches for the following
environment variables:
    CPP, CC, CXX, CPPFLAGS, CFLAGS, CXXFLAGS, LDFLAGS

These environment variables are empty by default, and as such ccompiler.py
defaults to either using the system tools (CC, CXX, and CPP) or leaving
the variables blank (LDFLAGS, CFLAGS, and CPPFLAGS.)

For autotools packages, this issue does not occur because autotools uses
Makefile.introspection found on the staging directory in
usr/share/gobject-introspection-1.0/ which automatically exports the above
variables.

However, for meson, the above variables are not exported when meson calls
g-ir-scanner to build .gir and .typelib files, which results in linking errors.

Exporting these variables in the g-ir-scanner wrapper fixes these issues and
ensures all build systems can generate .gir and .typelib files properly.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Tested-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gobject-introspection/g-ir-scanner.in
package/gobject-introspection/gobject-introspection.mk

index 9f97497b7ed7cba134a2aceed451f1f4416b4a55..22df7be3099f6a72d0d52395ca19f914bc26a50a 100644 (file)
@@ -1,6 +1,20 @@
 #!/usr/bin/env bash
 
+# These environment variables are empty by default, and as such ccompiler.py
+# defaults to either using the system tools (CC, CXX, and CPP) or leaving
+# the variables blank (LDFLAGS, CFLAGS, and CPPFLAGS.)
+# Export these variables to ensure all build systems can generate .gir and
+# .typelib files properly.
+export CPP="${CPP:-${HOST_DIR}/bin/@BASENAME_TARGET_CPP@}"
+export CC="${CC:-${HOST_DIR}/bin/@BASENAME_TARGET_CC@}"
+export CXX="${CXX:-${HOST_DIR}/bin/@BASENAME_TARGET_CXX@}"
+export CPPFLAGS="${CPPFLAGS:-@TARGET_CPPFLAGS@}"
+export CFLAGS="${CFLAGS:-@TARGET_CFLAGS@}"
+export CXXFLAGS="${CXXFLAGS:-@TARGET_CXXFLAGS@}"
+export LDFLAGS="${LDFLAGS:-@TARGET_LDFLAGS@}"
+
 export GI_SCANNER_DISABLE_CACHE=1
+
 ${HOST_DIR}/bin/g-ir-scanner \
 --lib-dirs-envvar=GIR_EXTRA_LIBS_PATH \
 --use-binary-wrapper=$(dirname $0)/g-ir-scanner-qemuwrapper \
index 35b6669469f04d23a5b0b96e85803d1c16038a98..0a395b814c2ff80bc0e5e463c60a67a8f9ddad4d 100644 (file)
@@ -105,6 +105,15 @@ define GOBJECT_INTROSPECTION_INSTALL_WRAPPERS
                $(INSTALL) -D -m 755 \
                        $(GOBJECT_INTROSPECTION_PKGDIR)/$(w).in $(STAGING_DIR)/usr/bin/$(w)
        )
+       $(SED) "s%@BASENAME_TARGET_CPP@%$(notdir $(TARGET_CPP))%g" \
+               -e "s%@BASENAME_TARGET_CC@%$(notdir $(TARGET_CC))%g" \
+               -e "s%@BASENAME_TARGET_CXX@%$(notdir $(TARGET_CXX))%g" \
+               -e "s%@TARGET_CPPFLAGS@%$(TARGET_CPPFLAGS)%g" \
+               -e "s%@TARGET_CFLAGS@%$(TARGET_CFLAGS)%g" \
+               -e "s%@TARGET_CXXFLAGS@%$(TARGET_CXXFLAGS)%g" \
+               -e "s%@TARGET_LDFLAGS@%$(TARGET_LDFLAGS)%g" \
+               $(STAGING_DIR)/usr/bin/g-ir-scanner
+
        # Gobject-introspection installs Makefile.introspection in
        # $(STAGING_DIR)/usr/share which is needed for autotools-based programs to
        # build .gir and .typelib files. Unfortuantly, gobject-introspection-1.0.pc