projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
90b9f1f
)
package/radvd: fix build without stack-protector
author
Fabrice Fontaine
<fontaine.fabrice@gmail.com>
Thu, 19 Nov 2020 12:03:47 +0000
(13:03 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Thu, 19 Nov 2020 21:58:20 +0000
(22:58 +0100)
Commit
6e85ab44493624748398ffb2c6bf4bda409f2de7
forgot to manage the new
--{with,without}-stack-protector option which has been added with
https://github.com/reubenhwk/radvd/commit/
f2cb35449f35b5815f3804161c968fde5ef2982b
and is enabled by default
Fixes:
- http://autobuild.buildroot.org/results/
e778df96f0a382a5b119724ee69f956ad455c452
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/radvd/radvd.mk
patch
|
blob
|
history
diff --git
a/package/radvd/radvd.mk
b/package/radvd/radvd.mk
index 7a650dc3c50a7038b749eee0838096f3a5673095..bed636784126497ac61b927784d39b30fde64dbc 100644
(file)
--- a/
package/radvd/radvd.mk
+++ b/
package/radvd/radvd.mk
@@
-15,6
+15,12
@@
RADVD_CONF_ENV = \
RADVD_LICENSE = BSD-4-Clause-like
RADVD_LICENSE_FILES = COPYRIGHT
+ifeq ($(BR2_TOOLCHAIN_HAS_SSP),y)
+RADVD_CONF_OPTS += --with-stack-protector
+else
+RADVD_CONF_OPTS += --without-stack-protector
+endif
+
# We don't provide /etc/radvd.conf, so disable the service by default.
define RADVD_INSTALL_INIT_SYSTEMD
$(INSTALL) -D -m 0644 package/radvd/50-radvd.preset \