package/busybox: check for config file
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 13 Jul 2015 10:32:03 +0000 (12:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 08:31:11 +0000 (10:31 +0200)
Add a check (before we call kconfig-package) that ensures the user has
set a kconfig-file.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/busybox/busybox.mk

index aab7f5d577cbf58d5fdc5e043bef1cfaed6960bc..d8c8bad318b5e4d70be0dca4b547205183e15627 100644 (file)
@@ -223,4 +223,12 @@ define BUSYBOX_INSTALL_INIT_SYSV
        $(BUSYBOX_INSTALL_TELNET_SCRIPT)
 endef
 
+# Checks to give errors that the user can understand
+# Must be before we call to kconfig-package
+ifeq ($(BR_BUILDING),y)
+ifeq ($(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG)),)
+$(error No BusyBox configuration file specified, check your BR2_PACKAGE_BUSYBOX_CONFIG setting)
+endif
+endif
+
 $(eval $(kconfig-package))