package/mongrel2: renumber patches
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 5 Sep 2020 12:42:02 +0000 (14:42 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 6 Sep 2020 07:41:20 +0000 (09:41 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/mongrel2/0001-Do-not-run-tests.patch [new file with mode: 0644]
package/mongrel2/0002-Do-not-run-tests.patch [deleted file]
package/mongrel2/0002-Fix-Makefiles-for-cross-compilation.patch [new file with mode: 0644]
package/mongrel2/0003-Fix-Makefiles-for-cross-compilation.patch [deleted file]
package/mongrel2/0003-Rename-symbol-to-prevent-conflict.patch [new file with mode: 0644]
package/mongrel2/0004-Rename-symbol-to-prevent-conflict.patch [deleted file]

diff --git a/package/mongrel2/0001-Do-not-run-tests.patch b/package/mongrel2/0001-Do-not-run-tests.patch
new file mode 100644 (file)
index 0000000..557c27e
--- /dev/null
@@ -0,0 +1,43 @@
+From 3cbef2195533f357c8a80c2840108662461273b7 Mon Sep 17 00:00:00 2001
+From: Lionel Orry <lionel.orry@gmail.com>
+Date: Wed, 27 Mar 2013 14:48:19 +0100
+Subject: [PATCH 4/4] Do not run tests.
+
+This patch is specific to cross-compiled environments and avoids running
+the tests on the host. It is not meant to be applied upstream.
+
+Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
+---
+ Makefile            | 2 +-
+ tools/m2sh/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 7dc4089..ca72630 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,7 +16,7 @@ TEST_SRC=$(wildcard tests/*_tests.c)
+ TESTS=$(patsubst %.c,%,${TEST_SRC})
+ MAKEOPTS=OPTFLAGS="${NOEXTCFLAGS} ${OPTFLAGS}" OPTLIBS="${OPTLIBS}" LIBS="${LIBS}" DESTDIR="${DESTDIR}" PREFIX="${PREFIX}"
+-all: bin/mongrel2 tests m2sh procer
++all: bin/mongrel2 m2sh procer filters config_modules
+ dev: CFLAGS=-g -Wall -Isrc -Wall -Wextra $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
+ dev: all
+diff --git a/tools/m2sh/Makefile b/tools/m2sh/Makefile
+index b50d8a0..334e4da 100644
+--- a/tools/m2sh/Makefile
++++ b/tools/m2sh/Makefile
+@@ -9,7 +9,7 @@ TESTS=$(patsubst %.c,%,${TEST_SRC})
+ LIB_SRC=$(filter-out src/m2sh.c,${SOURCES})
+ LIB_OBJ=$(filter-out src/m2sh.o,${OBJECTS})
+-all: ../lemon/lemon tests build/m2sh
++all: ../lemon/lemon build/m2sh
+ dev: CFLAGS=-g -Wall -Wextra -Isrc -I../../src $(OPTFLAGS)
+ dev: all
+-- 
+1.8.1.4
+
diff --git a/package/mongrel2/0002-Do-not-run-tests.patch b/package/mongrel2/0002-Do-not-run-tests.patch
deleted file mode 100644 (file)
index 557c27e..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From 3cbef2195533f357c8a80c2840108662461273b7 Mon Sep 17 00:00:00 2001
-From: Lionel Orry <lionel.orry@gmail.com>
-Date: Wed, 27 Mar 2013 14:48:19 +0100
-Subject: [PATCH 4/4] Do not run tests.
-
-This patch is specific to cross-compiled environments and avoids running
-the tests on the host. It is not meant to be applied upstream.
-
-Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
----
- Makefile            | 2 +-
- tools/m2sh/Makefile | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 7dc4089..ca72630 100644
---- a/Makefile
-+++ b/Makefile
-@@ -16,7 +16,7 @@ TEST_SRC=$(wildcard tests/*_tests.c)
- TESTS=$(patsubst %.c,%,${TEST_SRC})
- MAKEOPTS=OPTFLAGS="${NOEXTCFLAGS} ${OPTFLAGS}" OPTLIBS="${OPTLIBS}" LIBS="${LIBS}" DESTDIR="${DESTDIR}" PREFIX="${PREFIX}"
--all: bin/mongrel2 tests m2sh procer
-+all: bin/mongrel2 m2sh procer filters config_modules
- dev: CFLAGS=-g -Wall -Isrc -Wall -Wextra $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
- dev: all
-diff --git a/tools/m2sh/Makefile b/tools/m2sh/Makefile
-index b50d8a0..334e4da 100644
---- a/tools/m2sh/Makefile
-+++ b/tools/m2sh/Makefile
-@@ -9,7 +9,7 @@ TESTS=$(patsubst %.c,%,${TEST_SRC})
- LIB_SRC=$(filter-out src/m2sh.c,${SOURCES})
- LIB_OBJ=$(filter-out src/m2sh.o,${OBJECTS})
--all: ../lemon/lemon tests build/m2sh
-+all: ../lemon/lemon build/m2sh
- dev: CFLAGS=-g -Wall -Wextra -Isrc -I../../src $(OPTFLAGS)
- dev: all
--- 
-1.8.1.4
-
diff --git a/package/mongrel2/0002-Fix-Makefiles-for-cross-compilation.patch b/package/mongrel2/0002-Fix-Makefiles-for-cross-compilation.patch
new file mode 100644 (file)
index 0000000..730d8eb
--- /dev/null
@@ -0,0 +1,75 @@
+From 298356c44a7df2b34c4e307c531d2010e2cb4b79 Mon Sep 17 00:00:00 2001
+From: Lionel Orry <lionel.orry@gmail.com>
+Date: Wed, 27 Mar 2013 15:56:56 +0100
+Subject: [PATCH 1/1] Fix Makefiles for cross-compilation
+
+The CFLAGS handling in mongrel2 is really messy and it is hard to make
+it behave correctly with cross-compiling environments. This patch
+restricts the Makefiles syntax to GNU Make, but help cross-compiling.
+
+This is not meant to be applied upstream.
+
+Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
+---
+ Makefile                      | 2 +-
+ tools/config_modules/Makefile | 2 +-
+ tools/filters/Makefile        | 2 +-
+ tools/m2sh/Makefile           | 2 +-
+ tools/procer/Makefile         | 2 +-
+ 5 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 6dce4a6..d48e05e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS=-g -O2 -Wall -Wextra -Isrc -Isrc/polarssl/include -pthread -rdynamic -DNDEBUG $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
++override CFLAGS += -g -O2 -Wall -Wextra -Isrc -Isrc/polarssl/include -pthread -rdynamic -DNDEBUG $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
+ LIBS=-lzmq -ldl -lsqlite3 $(OPTLIBS)
+ PREFIX?=/usr/local
+diff --git a/tools/config_modules/Makefile b/tools/config_modules/Makefile
+index 398490c..53f2255 100644
+--- a/tools/config_modules/Makefile
++++ b/tools/config_modules/Makefile
+@@ -1,5 +1,5 @@
+ PREFIX?=/usr/local
+-CFLAGS=-I../../src -I../../src/polarssl/include $(OPTFLAGS) -fPIC -shared -nostartfiles -L../../build
++override CFLAGS += -I../../src -I../../src/polarssl/include $(OPTFLAGS) -fPIC -shared -nostartfiles -L../../build
+ LDFLAGS=$(OPTLIBS)
+ MONGO_SRC = mongo-c-driver/src/bson.c \
+diff --git a/tools/filters/Makefile b/tools/filters/Makefile
+index f9f4556..6077b79 100644
+--- a/tools/filters/Makefile
++++ b/tools/filters/Makefile
+@@ -1,5 +1,5 @@
+ PREFIX?=/usr/local
+-CFLAGS=-I../../src -I../../src/polarssl/include $(OPTFLAGS) -g -fPIC -shared -nostartfiles -L../../build
++ override CFLAGS += -I../../src -I../../src/polarssl/include $(OPTFLAGS) -g -fPIC -shared -nostartfiles -L../../build
+ LDFLAGS=$(OPTLIBS)
+ all: null.so
+diff --git a/tools/m2sh/Makefile b/tools/m2sh/Makefile
+index b50d8a0..ba378c5 100644
+--- a/tools/m2sh/Makefile
++++ b/tools/m2sh/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS=-DNDEBUG -DNO_LINENOS -pthread -g -I../../src -Isrc -Wall $(OPTFLAGS)
++override CFLAGS += -DNDEBUG -DNO_LINENOS -pthread -g -I../../src -Isrc -Wall $(OPTFLAGS)
+ LIBS=-lzmq -lsqlite3 ../../build/libm2.a $(OPTLIBS)
+ PREFIX?=/usr/local
+diff --git a/tools/procer/Makefile b/tools/procer/Makefile
+index d0d7de0..629b2e9 100644
+--- a/tools/procer/Makefile
++++ b/tools/procer/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS=-DNDEBUG -pthread -g -I../../src -Wall $(OPTFLAGS)
++override CFLAGS += -DNDEBUG -pthread -g -I../../src -Wall $(OPTFLAGS)
+ PREFIX?=/usr/local
+ LIBS?=-lzmq 
+ SOURCES=$(wildcard *.c)
+-- 
+1.8.1.4
+
diff --git a/package/mongrel2/0003-Fix-Makefiles-for-cross-compilation.patch b/package/mongrel2/0003-Fix-Makefiles-for-cross-compilation.patch
deleted file mode 100644 (file)
index 730d8eb..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-From 298356c44a7df2b34c4e307c531d2010e2cb4b79 Mon Sep 17 00:00:00 2001
-From: Lionel Orry <lionel.orry@gmail.com>
-Date: Wed, 27 Mar 2013 15:56:56 +0100
-Subject: [PATCH 1/1] Fix Makefiles for cross-compilation
-
-The CFLAGS handling in mongrel2 is really messy and it is hard to make
-it behave correctly with cross-compiling environments. This patch
-restricts the Makefiles syntax to GNU Make, but help cross-compiling.
-
-This is not meant to be applied upstream.
-
-Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
----
- Makefile                      | 2 +-
- tools/config_modules/Makefile | 2 +-
- tools/filters/Makefile        | 2 +-
- tools/m2sh/Makefile           | 2 +-
- tools/procer/Makefile         | 2 +-
- 5 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 6dce4a6..d48e05e 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,4 +1,4 @@
--CFLAGS=-g -O2 -Wall -Wextra -Isrc -Isrc/polarssl/include -pthread -rdynamic -DNDEBUG $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
-+override CFLAGS += -g -O2 -Wall -Wextra -Isrc -Isrc/polarssl/include -pthread -rdynamic -DNDEBUG $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
- LIBS=-lzmq -ldl -lsqlite3 $(OPTLIBS)
- PREFIX?=/usr/local
-diff --git a/tools/config_modules/Makefile b/tools/config_modules/Makefile
-index 398490c..53f2255 100644
---- a/tools/config_modules/Makefile
-+++ b/tools/config_modules/Makefile
-@@ -1,5 +1,5 @@
- PREFIX?=/usr/local
--CFLAGS=-I../../src -I../../src/polarssl/include $(OPTFLAGS) -fPIC -shared -nostartfiles -L../../build
-+override CFLAGS += -I../../src -I../../src/polarssl/include $(OPTFLAGS) -fPIC -shared -nostartfiles -L../../build
- LDFLAGS=$(OPTLIBS)
- MONGO_SRC = mongo-c-driver/src/bson.c \
-diff --git a/tools/filters/Makefile b/tools/filters/Makefile
-index f9f4556..6077b79 100644
---- a/tools/filters/Makefile
-+++ b/tools/filters/Makefile
-@@ -1,5 +1,5 @@
- PREFIX?=/usr/local
--CFLAGS=-I../../src -I../../src/polarssl/include $(OPTFLAGS) -g -fPIC -shared -nostartfiles -L../../build
-+ override CFLAGS += -I../../src -I../../src/polarssl/include $(OPTFLAGS) -g -fPIC -shared -nostartfiles -L../../build
- LDFLAGS=$(OPTLIBS)
- all: null.so
-diff --git a/tools/m2sh/Makefile b/tools/m2sh/Makefile
-index b50d8a0..ba378c5 100644
---- a/tools/m2sh/Makefile
-+++ b/tools/m2sh/Makefile
-@@ -1,4 +1,4 @@
--CFLAGS=-DNDEBUG -DNO_LINENOS -pthread -g -I../../src -Isrc -Wall $(OPTFLAGS)
-+override CFLAGS += -DNDEBUG -DNO_LINENOS -pthread -g -I../../src -Isrc -Wall $(OPTFLAGS)
- LIBS=-lzmq -lsqlite3 ../../build/libm2.a $(OPTLIBS)
- PREFIX?=/usr/local
-diff --git a/tools/procer/Makefile b/tools/procer/Makefile
-index d0d7de0..629b2e9 100644
---- a/tools/procer/Makefile
-+++ b/tools/procer/Makefile
-@@ -1,4 +1,4 @@
--CFLAGS=-DNDEBUG -pthread -g -I../../src -Wall $(OPTFLAGS)
-+override CFLAGS += -DNDEBUG -pthread -g -I../../src -Wall $(OPTFLAGS)
- PREFIX?=/usr/local
- LIBS?=-lzmq 
- SOURCES=$(wildcard *.c)
--- 
-1.8.1.4
-
diff --git a/package/mongrel2/0003-Rename-symbol-to-prevent-conflict.patch b/package/mongrel2/0003-Rename-symbol-to-prevent-conflict.patch
new file mode 100644 (file)
index 0000000..8369816
--- /dev/null
@@ -0,0 +1,45 @@
+From 8d0bc79f38913b1a55e7d151b32bbc9462c24b47 Mon Sep 17 00:00:00 2001
+From: Jason Miller <jason@jasom.org>
+Date: Fri, 14 Aug 2015 19:03:09 -0700
+Subject: [PATCH] Rename symbol to prevent conflict
+
+One of the standard headers defines max_align_t on some versions of linux.
+
+[Backported from upstream commit
+https://github.com/mongrel2/mongrel2/commit/563bac8c59b9b32205164d237cf1ec0cb48d189f.]
+
+Signed-off-by: Rodrigo Rebello <rprebello@gmail.com>
+---
+ src/mem/align.h  | 2 +-
+ src/mem/halloc.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/mem/align.h b/src/mem/align.h
+index 4c6e183..03a4999 100644
+--- a/src/mem/align.h
++++ b/src/mem/align.h
+@@ -30,7 +30,7 @@ union max_align
+       void (*q)(void);
+ };
+-typedef union max_align max_align_t;
++typedef union max_align h_max_align_t;
+ #endif
+diff --git a/src/mem/halloc.c b/src/mem/halloc.c
+index b097d1f..40d0c09 100644
+--- a/src/mem/halloc.c
++++ b/src/mem/halloc.c
+@@ -34,7 +34,7 @@ typedef struct hblock
+ #endif
+       hlist_item_t  siblings; /* 2 pointers */
+       hlist_head_t  children; /* 1 pointer  */
+-      max_align_t   data[1];  /* not allocated, see below */
++      h_max_align_t   data[1];  /* not allocated, see below */
+       
+ } hblock_t;
+-- 
+2.1.4
+
diff --git a/package/mongrel2/0004-Rename-symbol-to-prevent-conflict.patch b/package/mongrel2/0004-Rename-symbol-to-prevent-conflict.patch
deleted file mode 100644 (file)
index 8369816..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-From 8d0bc79f38913b1a55e7d151b32bbc9462c24b47 Mon Sep 17 00:00:00 2001
-From: Jason Miller <jason@jasom.org>
-Date: Fri, 14 Aug 2015 19:03:09 -0700
-Subject: [PATCH] Rename symbol to prevent conflict
-
-One of the standard headers defines max_align_t on some versions of linux.
-
-[Backported from upstream commit
-https://github.com/mongrel2/mongrel2/commit/563bac8c59b9b32205164d237cf1ec0cb48d189f.]
-
-Signed-off-by: Rodrigo Rebello <rprebello@gmail.com>
----
- src/mem/align.h  | 2 +-
- src/mem/halloc.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/mem/align.h b/src/mem/align.h
-index 4c6e183..03a4999 100644
---- a/src/mem/align.h
-+++ b/src/mem/align.h
-@@ -30,7 +30,7 @@ union max_align
-       void (*q)(void);
- };
--typedef union max_align max_align_t;
-+typedef union max_align h_max_align_t;
- #endif
-diff --git a/src/mem/halloc.c b/src/mem/halloc.c
-index b097d1f..40d0c09 100644
---- a/src/mem/halloc.c
-+++ b/src/mem/halloc.c
-@@ -34,7 +34,7 @@ typedef struct hblock
- #endif
-       hlist_item_t  siblings; /* 2 pointers */
-       hlist_head_t  children; /* 1 pointer  */
--      max_align_t   data[1];  /* not allocated, see below */
-+      h_max_align_t   data[1];  /* not allocated, see below */
-       
- } hblock_t;
--- 
-2.1.4
-