pkg-download: Fix DOWNLOAD_LOCALFILES
authorAndreas Naumann <anaumann@ultratronik.de>
Thu, 17 Jul 2014 14:47:02 +0000 (16:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 18 Jul 2014 18:01:46 +0000 (20:01 +0200)
The cp helperscript expects a filename as target, but just the folder
name was given.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/pkg-download.mk

index 7f208d538b0ea6408f50f34f6ee48e3b5881eca6..118591ce4895c6b8705d45b85d8f4b77969c5f62 100644 (file)
@@ -206,7 +206,7 @@ endef
 define DOWNLOAD_LOCALFILES
        test -e $(DL_DIR)/$(2) || \
        $(EXTRA_ENV) support/download/cp $(call stripurischeme,$(call qstrip,$(1))) \
-                                        $(DL_DIR) && \
+                                        $(DL_DIR)/$(2) && \
        $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_NAME).hash,$(DL_DIR)/$(2))
 endef