package/libraw: add optional support for lcms2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 30 Jan 2016 16:17:16 +0000 (17:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 Jan 2016 13:26:03 +0000 (14:26 +0100)
[Peter: also needs host-pkgconf]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libraw/libraw.mk

index 5ebc4a2de34e7ac0871247818438d48f49fbabdb..03f09f96f5add8376e1d9bd35b8ef40f6d5558d5 100644 (file)
@@ -12,7 +12,6 @@ LIBRAW_INSTALL_STAGING = YES
 LIBRAW_AUTORECONF = YES
 LIBRAW_CONF_OPTS += \
        --disable-examples \
-       --disable-lcms \
        --disable-openmp \
        --disable-demosaic-pack-gpl2 \
        --disable-demosaic-pack-gpl3
@@ -33,4 +32,11 @@ else
 LIBRAW_CONF_OPTS += --disable-jpeg
 endif
 
+ifeq ($(BR2_PACKAGE_LCMS2),y)
+LIBRAW_CONF_OPTS += --enable-lcms
+LIBRAW_DEPENDENCIES += lcms2 host-pkgconf
+else
+LIBRAW_CONF_OPTS += --disable-lcms
+endif
+
 $(eval $(autotools-package))