package/gauche: add optional mbedtls dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 18 Aug 2019 10:12:26 +0000 (12:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 19 Aug 2019 13:22:36 +0000 (15:22 +0200)
mbedtls support has been added in version 0.9.6 with
https://github.com/shirok/Gauche/commit/d449f013fae79639bb300d783962328c6b6b1bd0

So enable it if mbedtls is enabled and always enable embedded axTLS
support to keep existing behavior

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gauche/gauche.mk

index 1f66e28de7752543f609796fc6bf27f67ee76170..2a30a2b39a28b32a155f6683cbd7ead62571687f 100644 (file)
@@ -16,6 +16,16 @@ GAUCHE_AUTORECONF = YES
 HOST_GAUCHE_CONF_OPTS = --without-zlib
 GAUCHE_CONF_OPTS = --without-libatomic-ops
 
+# Enable embedded axTLS
+GAUCHE_TLS_LIBS = axtls
+
+ifeq ($(BR2_PACKAGE_MBEDTLS),y)
+GAUCHE_TLS_LIBS += mbedtls
+GAUCHE_DEPENDENCIES += mbedtls
+endif
+
+GAUCHE_CONF_OPTS += --with-tls="$(GAUCHE_TLS_LIBS)"
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 GAUCHE_CONF_OPTS += --with-zlib=$(STAGING_DIR)
 GAUCHE_DEPENDENCIES += zlib