projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4edc0f1
)
wine: Add OSMesa dependency
author
André Hentschel
<nerv@dawncrow.de>
Sat, 12 Dec 2015 19:55:38 +0000
(20:55 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Sun, 13 Dec 2015 13:29:33 +0000
(14:29 +0100)
We have support for building the OSMesa lib since
81537f284f62c6586d50bd5cca78c2bf1375b88c
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wine/wine.mk
patch
|
blob
|
history
diff --git
a/package/wine/wine.mk
b/package/wine/wine.mk
index 38576dbeb2e1e486c3018103fcf5596ea88c8796..1a1fea045af322185b7069e3063ad65686608fb1 100644
(file)
--- a/
package/wine/wine.mk
+++ b/
package/wine/wine.mk
@@
-27,7
+27,6
@@
WINE_CONF_OPTS = \
--without-hal \
--without-openal \
--without-opencl \
- --without-osmesa \
--without-oss
# Wine uses a wrapper around gcc, and uses the value of --host to
@@
-171,6
+170,13
@@
else
WINE_CONF_OPTS += --without-ldap
endif
+ifeq ($(BR2_PACKAGE_MESA3D_OSMESA),y)
+WINE_CONF_OPTS += --with-osmesa
+WINE_DEPENDENCIES += mesa3d
+else
+WINE_CONF_OPTS += --without-osmesa
+endif
+
ifeq ($(BR2_PACKAGE_SANE_BACKENDS),y)
WINE_CONF_OPTS += --with-sane
WINE_DEPENDENCIES += sane-backends