package/gvfs: add optional libfuse3 dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 14 Jul 2020 17:38:10 +0000 (19:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 15 Jul 2020 15:28:04 +0000 (17:28 +0200)
libfuse3 is an optional dependency since version 1.41.1 and
https://github.com/GNOME/gvfs/commit/7a0a06186b6fef07b8fce2360c04fd075fc84ed1

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gvfs/gvfs.mk

index 92a01ef2f6430f053069138954c67e28b1fd81d4..c5104e8dbf41d78b3f843504b783bdfeaf5abd90 100644 (file)
@@ -25,7 +25,6 @@ GVFS_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
 # Most of these are missing library support
 GVFS_CONF_OPTS = \
        -Dafc=false \
-       -Dfuse=false \
        -Dgoa=false \
        -Dgoogle=false \
        -Dmtp=false \
@@ -85,6 +84,13 @@ else
 GVFS_CONF_OPTS += -Dcdda=false
 endif
 
+ifeq ($(BR2_PACKAGE_LIBFUSE3),y)
+GVFS_DEPENDENCIES += libfuse3
+GVFS_CONF_OPTS += -Dfuse=true
+else
+GVFS_CONF_OPTS += -Dfuse=false
+endif
+
 # AFP support is anon-only without libgcrypt which isn't very useful
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 GVFS_CONF_OPTS += \