mtools: add support for building for target
authorFrank Hunleth <fhunleth@troodon-software.com>
Mon, 17 Mar 2014 22:30:58 +0000 (18:30 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 17 Mar 2014 22:48:40 +0000 (23:48 +0100)
This patch adds a menu option and updates the mtools.mk file to support
building mtools for the target.

[Peter: use same upstream URL as host variant]
Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/mtools/Config.in [new file with mode: 0644]
package/mtools/mtools.mk

index f9c1b0b1678730c86b8b566f3f9c9b74c5d9716c..688ed4dd725a967404afce5bd227185fe3b97103 100644 (file)
@@ -144,6 +144,7 @@ source "package/kobs-ng/Config.in"
 source "package/makedevs/Config.in"
 source "package/mmc-utils/Config.in"
 source "package/mtd/Config.in"
+source "package/mtools/Config.in"
 source "package/nfs-utils/Config.in"
 source "package/ntfs-3g/Config.in"
 source "package/squashfs/Config.in"
diff --git a/package/mtools/Config.in b/package/mtools/Config.in
new file mode 100644 (file)
index 0000000..c471d77
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_MTOOLS
+       bool "mtools"
+       depends on BR2_USE_WCHAR
+       help
+         Mtools is a collection of utilities to access MS-DOS disks from
+         Unix without mounting them. It supports Win'95 style long file
+         names, OS/2 Xdf disks and 2m disks (store up to 1992k on a high
+         density 3 1/2 disk).
+
+         http://www.gnu.org/software/mtools/
+
+comment "mtools needs a toolchain w/ wchar"
+       depends on !BR2_USE_WCHAR
index 11517dfc2ab2bfda0cb6d9999531c0e28669d6be..6d8f44bb25509a958a87a48b62c8a4a18c9de8c2 100644 (file)
@@ -10,4 +10,5 @@ MTOOLS_SITE          = $(BR2_GNU_MIRROR)/mtools/
 MTOOLS_LICENSE       = GPLv3+
 MTOOLS_LICENSE_FILES = COPYING
 
+$(eval $(autotools-package))
 $(eval $(host-autotools-package))