cc-tool: fix static build problem with boost regex
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 5 May 2015 21:36:45 +0000 (23:36 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 7 May 2015 20:21:33 +0000 (22:21 +0200)
The boost.m4 logic is a bit crappy, and needs some help to know that
boost_regex needs the pthread library.

Fixes:

  http://autobuild.buildroot.org/results/69a/69aff0b9d0ac8fe08e1d2f7ffb691f6a8fc8693b/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cc-tool/cc-tool.mk

index 7312bd384ebc43944c418c3fd92f1f4830eb9666..3a3f85ac42f606d82be36340ab56f93155f27cff 100644 (file)
@@ -14,4 +14,10 @@ CC_TOOL_DEPENDENCIES = boost libusb
 # Configure script "discovers" boost in /usr/local if not given explicitly
 CC_TOOL_CONF_OPTS = --with-boost=$(STAGING_DIR)/usr
 
+# Help boost.m4 find the Boost Regex library, which needs the pthread
+# library, but isn't detected using a modern (pkg-config) mechanism.
+ifeq ($(BR2_STATIC_LIBS),y)
+CC_TOOL_CONF_ENV += LIBS="-lpthread"
+endif
+
 $(eval $(autotools-package))