libpng: disable tools
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 27 Oct 2013 22:54:17 +0000 (19:54 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 28 Oct 2013 16:02:43 +0000 (17:02 +0100)
They can fail on some odd toolchain configurations because of
buildsystem shortcomings and aren't expected to be used in normal
scenarios.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libpng/libpng-01-disable-tools.patch [new file with mode: 0644]

diff --git a/package/libpng/libpng-01-disable-tools.patch b/package/libpng/libpng-01-disable-tools.patch
new file mode 100644 (file)
index 0000000..cd7040c
--- /dev/null
@@ -0,0 +1,30 @@
+Disable the new pngfix and png-fix-itxt tools: they take up space, fail to
+build on some oddball toolchain configurations and aren't expected/needed
+in a non-interactive embedded system.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura libpng-1.6.6.orig/Makefile.am libpng-1.6.6/Makefile.am
+--- libpng-1.6.6.orig/Makefile.am      2013-10-27 19:13:39.183376955 -0300
++++ libpng-1.6.6/Makefile.am   2013-10-27 19:13:50.388744191 -0300
+@@ -10,7 +10,7 @@
+ check_PROGRAMS= pngtest pngunknown pngstest pngvalid
+ # Utilities - installed
+-bin_PROGRAMS= pngfix png-fix-itxt
++bin_PROGRAMS=
+ pngtest_SOURCES = pngtest.c
+ pngtest_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
+diff -Nura libpng-1.6.6.orig/Makefile.in libpng-1.6.6/Makefile.in
+--- libpng-1.6.6.orig/Makefile.in      2013-10-27 19:13:39.180376856 -0300
++++ libpng-1.6.6/Makefile.in   2013-10-27 19:14:55.332872643 -0300
+@@ -59,7 +59,7 @@
+ host_triplet = @host@
+ check_PROGRAMS = pngtest$(EXEEXT) pngunknown$(EXEEXT) \
+       pngstest$(EXEEXT) pngvalid$(EXEEXT)
+-bin_PROGRAMS = pngfix$(EXEEXT) png-fix-itxt$(EXEEXT)
++bin_PROGRAMS =
+ @PNG_ARM_NEON_TRUE@am__append_1 = arm/arm_init.c\
+ @PNG_ARM_NEON_TRUE@   arm/filter_neon.S