Allow user to configure PROGRAM_INVOCATION_NAME
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Wed, 15 Aug 2007 22:35:26 +0000 (22:35 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Wed, 15 Aug 2007 22:35:26 +0000 (22:35 -0000)
package/coreutils/Config.in
package/tar/Config.in
toolchain/uClibc/Config.in
toolchain/uClibc/uclibc.mk

index 4722664ada8a5a8664007623490db5cc76e7c4fd..adc3782c113bc07fbaaab2b9c3f53100f1a848e0 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_COREUTILS
        bool "coreutils"
        default n
        depends on BR2_USE_WCHAR
+       select BR2_UCLIBC_PROGRAM_INVOCATION
        help
          All of the basic file/text/shell utilities.  These are the 
          core utilities which are expected to exist on every system.  
index c334c3ffae36f4b66e81ca3afd539b69c4a4da91..9116e2943095f0da4ea160dbf228fe260a875781 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_TAR
        bool "tar"
        default n
        depends on BR2_USE_WCHAR
+       select BR2_UCLIBC_PROGRAM_INVOCATION
        help
          A program that saves many files together into a single tape or disk 
          archive, and can restore individual files from the archive.
index a43161ca7b86a8c2ff9102469dc6f157e84b706c..455731c701e9c2a5c61dec349f35f71e00629dea 100644 (file)
@@ -82,3 +82,12 @@ config BR2_PTHREAD_DEBUG
        default n
        help
          Build the thread library with debugging enabled.
+
+config BR2_UCLIBC_PROGRAM_INVOCATION
+       bool "Enable 'program invocation name'"
+       default n
+       help
+         Support for the GNU-specific program_invocation_name and
+         program_invocation_short_name strings.  Some GNU packages 
+         (like tar and coreutils) utilize these for extra useful
+         output, but in general are not required.
index ebcc568620762720ae51f737c2d2655931e707fc..395558f9b522a9101e17305aac87af1abccf34c4 100644 (file)
@@ -229,6 +229,11 @@ ifeq ($(BR2_USE_WCHAR),y)
 else
        $(SED) 's,^.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=n,g' $(UCLIBC_DIR)/.oldconfig
 endif
+ifeq ($(BR2_UCLIBC_PROGRAM_INVOCATION),y)
+       echo "UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y" >> $(UCLIBC_DIR)/.oldconfig
+else
+       echo "# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set" >> $(UCLIBC_DIR)/.oldconfig
+endif
 ifeq ("$(KERNEL_ARCH)","i386")
        /bin/echo "# CONFIG_GENERIC_386 is not set" >> $(UCLIBC_DIR)/.oldconfig
        /bin/echo "# CONFIG_386 is not set" >> $(UCLIBC_DIR)/.oldconfig