projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
58aaf75
)
package/Makefile.in: search $(HOST_DIR) for host includes / libraries
author
Peter Korsgaard
<jacmet@sunsite.dk>
Mon, 16 Mar 2009 20:58:08 +0000
(20:58 -0000)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Mon, 16 Mar 2009 20:58:08 +0000
(20:58 -0000)
package/Makefile.in
patch
|
blob
|
history
diff --git
a/package/Makefile.in
b/package/Makefile.in
index 42f0fcd4ded46dfacfa1af5f473ec2205949e256..b94b5bc25db922e88d3d2a4a468777ffdb5ac5ff 100644
(file)
--- a/
package/Makefile.in
+++ b/
package/Makefile.in
@@
-185,6
+185,11
@@
INSTALL=/usr/bin/install
FLEX:=$(shell which flex || type -p flex)
BISON:=$(shell which bison || type -p bison)
+HOST_CFLAGS += -I$(HOST_DIR)/include -I$(HOST_DIR)/usr/include
+HOST_CXXFLAGS += -I$(HOST_DIR)/include -I$(HOST_DIR)/usr/include
+HOST_LDFLAGS += -L$(HOST_DIR)/lib -L$(HOST_DIR)/usr/lib
+
+
# hostcc version as an integer - E.G. 4.3.2 => 432
HOSTCC_VERSION:=$(shell $(HOSTCC) --version | \
sed -n 's/^.* \([0-9]*\)\.\([0-9]*\)\.\([0-9]*\)[ ]*.*$$/\1\2\3/p')