toolchain/helpers.mk: use --chmod on rsync
authorGuido Martínez <guido@vanguardiasur.com.ar>
Fri, 21 Nov 2014 16:19:02 +0000 (13:19 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Jul 2015 15:13:15 +0000 (17:13 +0200)
This makes sure we don't have any weird permissions on the staging dir,
which could affect the target.

Signed-off-by: Guido Martínez <guido@vanguardiasur.com.ar>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/helpers.mk

index 0dc1864bb72a4b76cd0541e6478d174b2723e801..895f3f14602ee4d776f2c311793c99628256c41e 100644 (file)
@@ -139,7 +139,7 @@ copy_toolchain_sysroot = \
        SUPPORT_LIB_DIR="$(strip $5)" ; \
        for i in etc $${ARCH_LIB_DIR} sbin usr usr/$${ARCH_LIB_DIR}; do \
                if [ -d $${ARCH_SYSROOT_DIR}/$$i ] ; then \
-                       rsync -au --chmod=Du+w --exclude 'usr/lib/locale' \
+                       rsync -au --chmod=u=rwX,go=rX --exclude 'usr/lib/locale' \
                                --exclude lib --exclude lib32 --exclude lib64 \
                                $${ARCH_SYSROOT_DIR}/$$i/ $(STAGING_DIR)/$$i/ ; \
                fi ; \