ljsyscall: remove dependency on some architecture
authorFrancois Perrad <fperrad@gmail.com>
Sat, 21 Mar 2015 12:01:37 +0000 (13:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 23 Mar 2015 18:14:39 +0000 (19:14 +0100)
ljsyscall is available for all arch supported by LuaJIT.
refactor LJSYSCALL_ARCH : dispatch all arch.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ljsyscall/Config.in
package/ljsyscall/ljsyscall.mk

index dcbd52185e7ad89e106054f84dc9b163a617e381..149e71d3fd7fb592f1889c05c7c1d5ec8ab8ebe0 100644 (file)
@@ -2,13 +2,11 @@ config BR2_PACKAGE_LJSYSCALL
        bool "ljsyscall"
        # ljsyscall is specifically for LuaJIT, not Lua.
        depends on BR2_PACKAGE_LUAJIT
-       # ljsyscall is only available for some target architectures
-       depends on BR2_i386 || BR2_x86_64 || BR2_powerpc || BR2_arm || BR2_armeb
        help
          An FFI implementation of the Linux and NetBSD kernel ABIs for LuaJIT.
 
          http://github.com/justincormack/ljsyscall
 
 comment "ljsyscall needs LuaJIT"
-       depends on !BR2_PACKAGE_LUAJIT && (BR2_i386 || BR2_x86_64 || BR2_powerpc || BR2_arm || BR2_armeb)
+       depends on !BR2_PACKAGE_LUAJIT
 
index a17da3fc21f343148ffd56ba1cd69e6f97d41465..1c6c2c111fa11061543cfdc834d8c4c891191e00 100644 (file)
@@ -9,13 +9,18 @@ LJSYSCALL_SITE = $(call github,justincormack,ljsyscall,$(LJSYSCALL_VERSION))
 LJSYSCALL_LICENSE = MIT
 LJSYSCALL_LICENSE_FILES = COPYRIGHT
 
+# dispatch all architectures of LuaJIT
 ifeq ($(BR2_i386),y)
 LJSYSCALL_ARCH = x86
 else ifeq ($(BR2_x86_64),y)
 LJSYSCALL_ARCH = x64
 else ifeq ($(BR2_powerpc),y)
 LJSYSCALL_ARCH = ppc
-else ifeq ($(LJSYSCALL_ARCH),)
+else ifeq ($(BR2_arm)$(BR2_armeb),y)
+LJSYSCALL_ARCH = arm
+else ifeq ($(BR2_mips)$(BR2_mipsel),y)
+LJSYSCALL_ARCH = mips
+else
 LJSYSCALL_ARCH = $(BR2_ARCH)
 endif