genromfs: use $(HOST_DIR) instead of $(HOST_DIR)/usr as prefix
authorArnout Vandecappelle <arnout@mind.be>
Wed, 5 Jul 2017 11:14:40 +0000 (13:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Jul 2017 14:06:38 +0000 (16:06 +0200)
genromfs is special because it uses "PREFIX" in the meaning of DESTDIR
and "prefix" in the meaning of prefix. We were up to know using it
incorrectly for host: PREFIX shouldn't be set and only prefix should
be set.

Add an explanatory comment for this unusual behaviour.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/genromfs/genromfs.mk

index 3025550637ceb015c6a222dcb0e7898df7160ea8..fd696b45b2e82b5cda68c2540468d4ff274a02bd 100644 (file)
@@ -16,6 +16,8 @@ define GENROMFS_BUILD_CMDS
                LDFLAGS="$(TARGET_LDFLAGS)"
 endef
 
+# "PREFIX" is the equivalent of DESTDIR in autotools, "prefix" is the
+# traditional prefix. "prefix" defaults to /usr so no need to set it.
 define GENROMFS_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) PREFIX=$(TARGET_DIR) install
 endef
@@ -25,7 +27,7 @@ define HOST_GENROMFS_BUILD_CMDS
 endef
 
 define HOST_GENROMFS_INSTALL_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) PREFIX=$(HOST_DIR) install
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) prefix=$(HOST_DIR) install
 endef
 
 $(eval $(generic-package))