iproute2: use @D instead of IPROUTE2_DIR
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 5 Aug 2016 17:08:00 +0000 (19:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Aug 2016 21:05:26 +0000 (23:05 +0200)
We more generally use $(@D) instead of $(pkg_DIR) to refer to the
package source directory, so this commit updates iproute2 to also use
$(@D) everywhere.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/iproute2/iproute2.mk

index edc17ad75b1426b006f0b551c3f8759ad8d490f4..09e68c5ec344c7b0e877b64c463d983382942818 100644 (file)
@@ -27,13 +27,13 @@ ifeq ($(BR2_PACKAGE_IPTABLES)x$(BR2_STATIC_LIBS),yx)
 IPROUTE2_DEPENDENCIES += iptables
 define IPROUTE2_WITH_IPTABLES
        # Makefile is busted so it never passes IPT_LIB_DIR properly
-       $(SED) "s/-DIPT/-DXT/" $(IPROUTE2_DIR)/tc/Makefile
+       $(SED) "s/-DIPT/-DXT/" $(@D)/tc/Makefile
 endef
 else
 define IPROUTE2_WITH_IPTABLES
        # em_ipset needs xtables, but configure misdetects it
-       echo "TC_CONFIG_IPSET:=n" >>$(IPROUTE2_DIR)/Config
-       echo "TC_CONFIG_XT:=n" >>$(IPROUTE2_DIR)/Config
+       echo "TC_CONFIG_IPSET:=n" >>$(@D)/Config
+       echo "TC_CONFIG_XT:=n" >>$(@D)/Config
 endef
 endif
 
@@ -42,7 +42,7 @@ ifeq ($(BR2_PACKAGE_BERKELEYDB_COMPAT185)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
 IPROUTE2_DEPENDENCIES += berkeleydb
 else
 define IPROUTE2_DISABLE_ARPD
-       echo "HAVE_BERKELEY_DB:=n" >> $(IPROUTE2_DIR)/Config
+       echo "HAVE_BERKELEY_DB:=n" >> $(@D)/Config
 endef
 endif