moarvm: use pkgconfig to find libraries and headers
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Wed, 23 Nov 2016 14:39:10 +0000 (14:39 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Nov 2016 21:41:58 +0000 (22:41 +0100)
MoarVM's Configure.pl script uses pkgconfig to find libraries and
headers, but it uses the one installed in the host machine which is
wrong and can lead to errors of unsafe include paths.

Instead, make it depend on the host-pkgconf package and specify the path
to our pkgconfig binary by using the --pkgconfig configure option.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/moarvm/moarvm.mk

index 644432eda7cd99078b8d401df90786895a8545bb..80bd19c92d5c9d532e47b97a42545c91bca52ea6 100644 (file)
@@ -10,7 +10,7 @@ MOARVM_SOURCE = MoarVM-$(MOARVM_VERSION).tar.gz
 MOARVM_LICENSE = Artistic-2.0
 MOARVM_LICENSE_FILES = Artistic2.txt
 MOARVM_INSTALL_STAGING = YES
-MOARVM_DEPENDENCIES = host-luajit libuv libtommath libatomic_ops
+MOARVM_DEPENDENCIES = host-luajit host-pkgconf libuv libtommath libatomic_ops
 
 MOARVM_CONF_OPTS = \
        --build=$(GNU_HOST_NAME) \
@@ -19,6 +19,7 @@ MOARVM_CONF_OPTS = \
        --cc="$(TARGET_CC)" \
        --ld="$(TARGET_CC)" \
        --prefix="/usr" \
+       --pkgconfig=$(PKG_CONFIG_HOST_BINARY) \
        --lua=$(HOST_DIR)/usr/bin/luajit \
        --has-libuv \
        --has-libtommath \