Revert "libglib2: bump to version 2.50.0"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Oct 2016 13:12:15 +0000 (15:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Oct 2016 13:12:15 +0000 (15:12 +0200)
This reverts commit 4c7c010f9fae01399070844991252d3f5b9aae5f.

The bump to libglib2 2.25.0 causes a large number of build failures due
to the redefinition of crc32() in both util-linux libblkid and
zlib.

Fixes:

  http://autobuild.buildroot.net/results/ac65c9177dd63fc8d76dba3b9845f81b15faa716/
  (and approximately 500 other similar build failures)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libglib2/Config.in
package/libglib2/libglib2.hash
package/libglib2/libglib2.mk

index 80c7d6749b34e64ee56c19167c33c33cc9785404..84ee816a895d91fad0333fad29995479b3838d4a 100644 (file)
@@ -5,8 +5,6 @@ config BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBFFI
        select BR2_PACKAGE_PCRE
        select BR2_PACKAGE_PCRE_UCP
-       select BR2_PACKAGE_UTIL_LINUX
-       select BR2_PACKAGE_UTIL_LINUX_LIBMOUNT
        select BR2_PACKAGE_ZLIB
        depends on BR2_USE_WCHAR # gettext
        depends on BR2_TOOLCHAIN_HAS_THREADS
index 3bc4021477d69d85627d66477c6d06a478199d84..35728e2e332ea16ec4cf1d035e3bfc9b0b229b4e 100644 (file)
@@ -1,2 +1,2 @@
-# https://download.gnome.org/sources/glib/2.50/glib-2.50.0.sha256sum
-sha256  830b551fa626bda06e12729205b3c5bb0d82b924a8cf64d948945878f01b7d70  glib-2.50.0.tar.xz
+# https://download.gnome.org/sources/glib/2.48/glib-2.48.2.sha256sum
+sha256  f25e751589cb1a58826eac24fbd4186cda4518af772806b666a3f91f66e6d3f4  glib-2.48.2.tar.xz
index 5bc6ed5f6d31c0e8b713a32b67be110e56501ae7..6b1a38794605dd9133143d64c91182326461d19a 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-LIBGLIB2_VERSION_MAJOR = 2.50
-LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).0
+LIBGLIB2_VERSION_MAJOR = 2.48
+LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).2
 LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.xz
 LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
 LIBGLIB2_LICENSE = LGPLv2+
@@ -102,7 +102,7 @@ HOST_LIBGLIB2_CONF_OPTS = \
 
 LIBGLIB2_DEPENDENCIES = \
        host-pkgconf host-libglib2 host-gettext \
-       libffi pcre util-linux zlib $(if $(BR2_NEEDS_GETTEXT),gettext)
+       libffi pcre zlib $(if $(BR2_NEEDS_GETTEXT),gettext)
 
 HOST_LIBGLIB2_DEPENDENCIES = \
        host-gettext host-libffi host-pcre host-pkgconf host-zlib