powerpc: add BR2_POWERPC_CPU_HAS_ALTIVEC to replace adhoc deps/checks
authorCody P Schafer <cody@linux.vnet.ibm.com>
Tue, 13 May 2014 05:28:17 +0000 (22:28 -0700)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 26 May 2014 19:14:08 +0000 (21:14 +0200)
Signed-off-by: Cody P Schafer <cody@linux.vnet.ibm.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
arch/Config.in.powerpc
package/efl/libevas/libevas.mk
package/ffmpeg/ffmpeg.mk
package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk
package/gstreamer1/gst1-libav/gst1-libav.mk
package/mpg123/mpg123.mk
package/vlc/vlc.mk

index cb8935c9da531cbc07856eabfa542810bf0e085a..847910377b493bd9f64028e1c322b28a380f3d5e 100644 (file)
@@ -1,3 +1,6 @@
+config BR2_POWERPC_CPU_HAS_ALTIVEC
+       bool
+
 config BR2_POWERPC_CPU_HAS_SPE
        bool
 
@@ -51,8 +54,10 @@ config BR2_powerpc_740
        bool "740"
 config BR2_powerpc_7400
        bool "7400"
+       select BR2_POWERPC_CPU_HAS_ALTIVEC
 config BR2_powerpc_7450
        bool "7450"
+       select BR2_POWERPC_CPU_HAS_ALTIVEC
 config BR2_powerpc_750
        bool "750"
 config BR2_powerpc_821
@@ -63,6 +68,7 @@ config BR2_powerpc_860
        bool "860"
 config BR2_powerpc_970
        bool "970"
+       select BR2_POWERPC_CPU_HAS_ALTIVEC
 config BR2_powerpc_8540
        bool "8540 / e500v1"
        select BR2_POWERPC_CPU_HAS_SPE
index 41ceb49cc9d0bfcc17a7c07b130982e5c8621b84..71f1aeb78522e07467b42ab5c664696a883a1bfb 100644 (file)
@@ -136,7 +136,7 @@ else
 LIBEVAS_CONF_OPT += --disable-cpu-sse3
 endif
 
-ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
+ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
 LIBEVAS_CONF_OPT += --enable-cpu-altivec
 else
 LIBEVAS_CONF_OPT += --disable-cpu-altivec
index a0a15a3cc1a1798b4301fb8eecc63d90c5f982f7..5510b809848a25d9fde6468924458f8ba38d3f29 100644 (file)
@@ -299,14 +299,11 @@ FFMPEG_CONF_OPT += \
        --disable-mipsdspr2
 endif
 
-# Set powerpc altivec appropriately
-ifeq ($(BR2_powerpc),y)
-ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
+ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
 FFMPEG_CONF_OPT += --enable-altivec
 else
 FFMPEG_CONF_OPT += --disable-altivec
 endif
-endif
 
 ifeq ($(BR2_PREFER_STATIC_LIB),)
 FFMPEG_CONF_OPT += --enable-pic
index f18ab1821ed1e80cba4cde354978345e78e6c1f1..5c4b7543b8b046ec4fc0d970e243b3ea0a09b24f 100644 (file)
@@ -63,14 +63,11 @@ ifeq ($(BR2_ARM_CPU_HAS_NEON),y)
 GST_FFMPEG_CONF_EXTRA_OPT += --enable-neon
 endif
 
-# Set powerpc altivec appropriately
-ifeq ($(BR2_powerpc),y)
-ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
+ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
 GST_FFMPEG_CONF_EXTRA_OPT += --enable-altivec
 else
 GST_FFMPEG_CONF_EXTRA_OPT += --disable-altivec
 endif
-endif
 
 ifeq ($(BR2_PREFER_STATIC_LIB),)
 GST_FFMPEG_CONF_EXTRA_OPT += --enable-pic
index 7a0182e45cfb37a733ef82a49ed06d5eb2b38adb..f84bcb2cc001db595d03ba9dda01424443f62d22 100644 (file)
@@ -71,14 +71,11 @@ else
 GST1_LIBAV_CONF_EXTRA_OPT += --disable-vfp
 endif
 
-# Set powerpc altivec appropriately
-ifeq ($(BR2_powerpc),y)
-ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
+ifeq ($(BR2_POWERPC_CPU_HASH_ALTIVEC),y)
 GST1_LIBAV_CONF_EXTRA_OPT += --enable-altivec
 else
 GST1_LIBAV_CONF_EXTRA_OPT += --disable-altivec
 endif
-endif
 
 GST1_LIBAV_CONF_OPT = \
        --with-libav-extra-configure="$(GST1_LIBAV_CONF_EXTRA_OPT)"
index a950813c73203663f4d8a157773b8c003c0fd2a2..d66592cd700d85d11dccb530acb08acd27a65bff 100644 (file)
@@ -22,14 +22,12 @@ ifeq ($(BR2_i386),y)
 MPG123_CPU = x86
 endif
 
-ifeq ($(BR2_powerpc),y)
-ifneq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),)
+ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
 MPG123_CPU = altivec
 endif
 ifeq ($(BR2_SOFT_FLOAT),y)
 MPG123_CPU = ppc_nofpu
 endif
-endif
 
 ifeq ($(BR2_x86_64),y)
 MPG123_CPU = x86-64
index e14c9c3d4a48d87d9544ab4ab1781f6cfa97154f..6eb7eead9bdd92e29866c4dd37e04dffef35156e 100644 (file)
@@ -49,8 +49,7 @@ ifeq ($(BR2_PREFER_STATIC_LIB),)
 VLC_CONF_OPT += --disable-static
 endif
 
-# Set powerpc altivec appropriately
-ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
+ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
 VCL_CONF_OPT += --enable-altivec
 else
 VLC_CONF_OPT += --disable-altivec