package/vlc: use only glesv2, not glesv1
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 22 Apr 2015 21:23:28 +0000 (23:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Apr 2015 21:47:11 +0000 (23:47 +0200)
Fixes
http://autobuild.buildroot.net/results/0be/0bee8646c2dd7dd2c201ee2986f3e802277314a5/
http://autobuild.buildroot.net/results/64a/64a1a6d39b72b9dec4231b9f28ca14b38989d7df/
http://autobuild.buildroot.net/results/b6b/b6b66e0b24d985462ca8dbefedd740453ca42293/
http://autobuild.buildroot.net/results/497/4976f5e9dc53e6f9f29d9d45f0fb9bd42c7ab1ea/

and many others

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index e77d4fa44852bf8930096657f11abbf3eae4b3ef..b937b79459e8a85b5273fa35a1756aebdbbcfbcd 100644 (file)
@@ -24,6 +24,7 @@ endef
 VLC_POST_PATCH_HOOKS += VLC_OVERRIDE_PKG_M4
 
 VLC_CONF_OPTS += \
+       --disable-gles1 \
        --disable-a52 \
        --disable-shout \
        --disable-twolame \
@@ -137,10 +138,10 @@ VLC_DEPENDENCIES += libgl
 endif
 
 ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
-VLC_CONF_OPTS += --enable-gles1 --enable-gles2
+VLC_CONF_OPTS += --enable-gles2
 VLC_DEPENDENCIES += libgles
 else
-VLC_CONF_OPTS += --disable-gles1 --disable-gles2
+VLC_CONF_OPTS += --disable-gles2
 endif
 
 ifeq ($(BR2_PACKAGE_OPUS),y)