quazip: new package
authorZoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Mon, 13 Jul 2015 00:38:09 +0000 (02:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Jul 2015 21:50:02 +0000 (23:50 +0200)
[Thomas:
 - fix indentation of select BR2_PACKAGE_ZLIB in Config.in
 - rewrap Config.in help text, lines were too long
 - remove depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5, since
   quazip/Config.in is already only included if one of Qt4 or Qt5 is
   enabled.
 - remove QUAZIP_SOURCE definition, since its value was the default
 - add the missing zlib dependency in the .mk file
 - add spaces around '=' signs when setting QUAZIP_QMAKE
 - pass $(TARGET_MAKE_ENV) at install time]

Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/quazip/Config.in [new file with mode: 0644]
package/quazip/quazip.hash [new file with mode: 0644]
package/quazip/quazip.mk [new file with mode: 0644]

index ddbf18029b7a3daf5f53ba9649ba115f436a0c82..20ecd38534b2a251ac816a5418a954a31175e143 100644 (file)
@@ -265,6 +265,7 @@ comment "QT libraries and helper libraries"
        source "package/qextserialport/Config.in"
        source "package/qjson/Config.in"
        source "package/qtuio/Config.in"
+       source "package/quazip/Config.in"
        source "package/qwt/Config.in"
 endif
        source "package/weston/Config.in"
diff --git a/package/quazip/Config.in b/package/quazip/Config.in
new file mode 100644 (file)
index 0000000..83537d4
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_QUAZIP
+       bool "quazip"
+       select BR2_PACKAGE_ZLIB
+       help
+         QuaZIP is a simple C++ wrapper over Gilles Vollant's
+         ZIP/UNZIP package that can be used to access ZIP
+         archives. It uses the Qt toolkit.
+
+         http://quazip.sourceforge.net
diff --git a/package/quazip/quazip.hash b/package/quazip/quazip.hash
new file mode 100644 (file)
index 0000000..84b56c7
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 78c984103555c51e6f7ef52e3a2128e2beb9896871b2cc4d4dbd4d64bff132de quazip-0.7.1.tar.gz
diff --git a/package/quazip/quazip.mk b/package/quazip/quazip.mk
new file mode 100644 (file)
index 0000000..178a531
--- /dev/null
@@ -0,0 +1,39 @@
+################################################################################
+#
+# quazip
+#
+################################################################################
+
+QUAZIP_VERSION = 0.7.1
+QUAZIP_SITE = http://sourceforge.net/projects/quazip/files/quazip/$(QUAZIP_VERSION)/
+QUAZIP_INSTALL_STAGING = YES
+QUAZIP_DEPENDENCIES = \
+       zlib \
+       $(if $(BR2_PACKAGE_QT),qt) \
+       $(if $(BR2_PACKAGE_QT5),qt5base)
+QUAZIP_LICENSE = LGPLv2.1
+QUAZIP_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_QT5),y)
+QUAZIP_QMAKE = $(QT5_QMAKE)
+else
+QUAZIP_QMAKE = $(QT_QMAKE)
+endif
+
+define QUAZIP_CONFIGURE_CMDS
+       (cd $(@D); $(TARGET_MAKE_ENV) $(QUAZIP_QMAKE) PREFIX=/usr)
+endef
+
+define QUAZIP_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define QUAZIP_INSTALL_STAGING_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install INSTALL_ROOT=$(STAGING_DIR)
+endef
+
+define QUAZIP_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install INSTALL_ROOT=$(TARGET_DIR)
+endef
+
+$(eval $(generic-package))