jimtcl: don't attempt to handle ccache internally
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Fri, 14 Feb 2014 20:57:39 +0000 (21:57 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Feb 2014 16:09:17 +0000 (17:09 +0100)
jimtcl tries to use 'ccache' (a non-buildroot host version) which may not
exist on the host system. If ccache is enabled in buildroot, the compiler
used by jimtcl is:
ccache <buildroot>/.../ccache <buildroot>/.../<tuple>-gcc

If ccache is not present on the host, this results in the build error:

ccache <buildroot>/.../ccache <buildroot>/.../<tuple>-gcc
-D_GNU_SOURCE -Wall  -I. -fpic -pipe -Os    -c -o jim-subcmd.o jim-subcmd.c
make[1]: ccache: Command not found

This patch passes 'CCACHE=none' to the 'configure' script, disabling the
internal handling of ccache, so that ccache can be transparently passed
through CC.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/jimtcl/jimtcl.mk

index 53cddf9455c7b5d6f07c9be571f9143436f0ff66..1f2ea82db156255a8421af9624a15a0960fe61e5 100644 (file)
@@ -38,7 +38,7 @@ endif
 
 define JIMTCL_CONFIGURE_CMDS
        (cd $(@D); \
-               $(TARGET_CONFIGURE_OPTS) \
+               $(TARGET_CONFIGURE_OPTS) CCACHE=none \
                ./configure --prefix=/usr \
                $(JIMTCL_SHARED) \
        )