xstroke: fix dependencies
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Aug 2010 20:52:01 +0000 (22:52 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Aug 2010 20:52:01 +0000 (22:52 +0200)
xstroke doesn't need docker, but it does need libXft/Xtst/Xpm.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/xstroke/Config.in
package/xstroke/xstroke.mk

diff --git a/CHANGES b/CHANGES
index d9607c2f09137bf0beaa4487e2fcb949e0bb1b40..904a92f3e857d9cdacb259b31b2b0f1d214f488e 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,7 @@
 
        Fixes all over the tree.
 
-       Updated/fixed packages: atk
+       Updated/fixed packages: atk, xstroke
 
 2010.08-rc2, Released August 30th, 2010:
 
index 3d68b3e2f731ce3d4025133f997b4bcc5914c814..5589fe6a4f6f6baee64c01a180ef1ce385e0878c 100644 (file)
@@ -1,12 +1,10 @@
 config BR2_PACKAGE_XSTROKE
        bool "xstroke"
        depends on BR2_PACKAGE_XORG7
-       depends on BR2_USE_WCHAR # glib2
-       select BR2_PACKAGE_DOCKER
+       select BR2_PACKAGE_XLIB_LIBXFT
+       select BR2_PACKAGE_XLIB_LIBXTST
+       select BR2_PACKAGE_XLIB_LIBXPM
        help
          Handwriting recognition for X
 
          http://avr32linux.org/twiki/pub/Main/XStroke
-
-comment "xstroke requires a toolchain with WCHAR support"
-       depends on BR2_PACKAGE_XORG7 && !BR2_USE_WCHAR
index bfe66ccf4c5dcafdabe887d6cd3feae54d631551..920ed9cacc0c747e5fe0f636bf8308f702fcea70 100644 (file)
@@ -6,12 +6,9 @@
 XSTROKE_VERSION = 0.6
 XSTROKE_SOURCE = xstroke-$(XSTROKE_VERSION).tar.gz
 XSTROKE_SITE = http://avr32linux.org/twiki/pub/Main/XStroke
-XSTROKE_AUTORECONF = NO
-XSTROKE_INSTALL_STAGING = NO
-XSTROKE_INSTALL_TARGET = YES
 XSTROKE_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
 
-XSTROKE_DEPENDENCIES = xserver_xorg-server
+XSTROKE_DEPENDENCIES = xlib_libXft xlib_libXtst xlib_libXpm
 
 $(eval $(call AUTOTARGETS,package,xstroke))