add support for using busybox snapshot
authorMike Frysinger <vapier@gentoo.org>
Sat, 9 Oct 2004 18:00:34 +0000 (18:00 -0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 9 Oct 2004 18:00:34 +0000 (18:00 -0000)
package/busybox/Config.in
package/busybox/busybox.mk

index befe2b890ed096eb5ef8c3aa120624e52acbe4b7..afa14fd41533027b053e226ecfca30d75f134190 100644 (file)
@@ -9,3 +9,11 @@ config BR2_PACKAGE_BUSYBOX
 
          Most people will answer Y.
 
+config BR2_PACKAGE_BUSYBOX_SNAPSHOT
+       bool "Use the daily snapshot of busybox?"
+       depends BR2_PACKAGE_BUSYBOX
+       default y
+       help
+         Use the latest busybox CVS snapshot instead of release.
+
+         For fun, you should say Y.
index 571a17f10bf96b85acef5edaf53ad8ffaee5c953..f985d6e9113a96092cb46ffde0875e78fb33740b 100644 (file)
@@ -4,14 +4,15 @@
 #
 #############################################################
 
-ifneq ($(strip $(USE_BUSYBOX_SNAPSHOT)),)
+ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
 # Be aware that this changes daily....
 BUSYBOX_DIR:=$(BUILD_DIR)/busybox
-BUSYBOX_SOURCE:=busybox-$(strip $(USE_BUSYBOX_SNAPSHOT)).tar.bz2
+BUSYBOX_SOURCE:=busybox-snapshot.tar.bz2
 BUSYBOX_SITE:=http://www.busybox.net/downloads/snapshots
 else
-BUSYBOX_DIR:=$(BUILD_DIR)/busybox-1.00-rc2
-BUSYBOX_SOURCE:=busybox-1.00-rc2.tar.bz2
+BUSYBOX_VER:=1.00-rc3
+BUSYBOX_DIR:=$(BUILD_DIR)/busybox-$(BUSYBOX_VER)
+BUSYBOX_SOURCE:=busybox-$(BUSYBOX_VER).tar.bz2
 BUSYBOX_SITE:=http://www.busybox.net/downloads
 endif
 BUSYBOX_UNZIP=bzcat