php: fix build for xtensa
authorBaruch Siach <baruch@tkos.co.il>
Tue, 31 Dec 2013 09:07:29 +0000 (11:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Dec 2013 10:57:48 +0000 (11:57 +0100)
The php package generates a binary that is too large for the xtensa default
placement of literals in a dedicated section. Use -mtext-section-literal to
place literals in the text section.

Fixes
http://autobuild.buildroot.net/results/a9a/a9a1063104402ec28e01560ec7c8f8a5b6d43dd5/.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/php.mk

index 10c314f857d8df1d99c29d17a9310f1de0903e39..f31217e774d8999826ed199b92fc5cc4f7496ed5 100644 (file)
@@ -36,6 +36,10 @@ ifneq ($(BR2_INET_IPV6),y)
 endif
 endif
 
+ifeq ($(BR2_xtensa),y)
+PHP_CFLAGS += -mtext-section-literals
+endif
+
 PHP_CONF_OPT += $(if $(BR2_PACKAGE_PHP_CLI),,--disable-cli)
 PHP_CONF_OPT += $(if $(BR2_PACKAGE_PHP_CGI),,--disable-cgi)