lua-testmore: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 24 Feb 2014 07:34:52 +0000 (08:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 15:17:21 +0000 (16:17 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lua-testmore/Config.in [new file with mode: 0644]
package/lua-testmore/lua-testmore.mk [new file with mode: 0644]

index 684d75662fca6914ad34a2c6dee7b4ec062b7f4f..0085e85da80376d82785d1e352f964c8191173c8 100644 (file)
@@ -380,6 +380,7 @@ source "package/lrandom/Config.in"
 source "package/lua-cjson/Config.in"
 source "package/lua-ev/Config.in"
 source "package/lua-msgpack-native/Config.in"
+source "package/lua-testmore/Config.in"
 source "package/luasql-sqlite3/Config.in"
 source "package/luabitop/Config.in"
 source "package/luacrypto/Config.in"
diff --git a/package/lua-testmore/Config.in b/package/lua-testmore/Config.in
new file mode 100644 (file)
index 0000000..61dea3a
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LUA_TESTMORE
+       bool "lua-testmore"
+       help
+         an Unit Testing Framework.
+
+         http://fperrad.github.io/lua-TestMore/
diff --git a/package/lua-testmore/lua-testmore.mk b/package/lua-testmore/lua-testmore.mk
new file mode 100644 (file)
index 0000000..fcbb170
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# lua-testmore
+#
+################################################################################
+
+LUA_TESTMORE_VERSION_UPSTREAM = 0.3.1
+LUA_TESTMORE_VERSION = $(LUA_TESTMORE_VERSION_UPSTREAM)-1
+LUA_TESTMORE_SUBDIR  = lua-TestMore-$(LUA_TESTMORE_VERSION_UPSTREAM)
+LUA_TESTMORE_LICENSE = MIT
+LUA_TESTMORE_LICENSE_FILES = $(LUA_TESTMORE_SUBDIR)/COPYRIGHT
+
+$(eval $(luarocks-package))