host util-linux: disable login and su since they depend on PAM
authorChristophe Vu-Brugier <cvubrugier@lacie.com>
Mon, 11 Mar 2013 06:19:37 +0000 (06:19 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 18 Mar 2013 21:54:16 +0000 (22:54 +0100)
This fixes the following errors when building util-linux v2.22.2 for
the host in case the PAM headers are missing:

  configure: error: login selected, but required PAM header file not available
  configure: error: su selected, but required PAM header file not available

Signed-off-by: Christophe Vu-Brugier <cvubrugier@lacie.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/util-linux/util-linux.mk

index 5e8820604ebc1883e0e462a484d7106fe861ef9f..b562206488fe018fb2773f8e49b5f0a5f97e390a 100644 (file)
@@ -79,11 +79,12 @@ UTIL_LINUX_CONF_OPT += \
 # and none of the util-linux utilities, so we disable all of them.
 HOST_UTIL_LINUX_CONF_OPT += \
        --enable-libuuid \
-       --disable-mount --disable-fsck --disable-libmount \
-       --disable-uuidd --disable-libblkid --disable-agetty \
-       --disable-cramfs --disable-switch_root --disable-pivot_root \
-       --disable-fallocate --disable-unshare --disable-rename \
-       --disable-schedutils --disable-wall --disable-partx
+       --disable-agetty --disable-cramfs --disable-fallocate \
+       --disable-fsck --disable-libblkid --disable-libmount \
+       --disable-login --disable-mount --disable-partx \
+       --disable-pivot_root --disable-rename --disable-schedutils \
+       --disable-su --disable-switch_root --disable-unshare \
+       --disable-uuidd --disable-wall
 
 # Avoid building the tools if they are disabled since we can't install on
 # a per-directory basis.