package/systemd: add optional support for bootchart
authorGabe Evans <gabe@hashrabbit.co>
Thu, 25 Feb 2016 21:55:21 +0000 (21:55 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Feb 2016 21:54:16 +0000 (22:54 +0100)
Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
[Thomas: rewrap Config.in help text.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index f1cd465c8155e47d565f7d3b448314b84eea6e62..85dcf07639b31bd2264a094ec91429887de2f256 100644 (file)
@@ -100,6 +100,16 @@ config BR2_PACKAGE_SYSTEMD_VCONSOLE
 
          http://www.freedesktop.org/software/systemd/man/systemd-vconsole-setup.service.html
 
+config BR2_PACKAGE_SYSTEMD_BOOTCHART
+       bool "enable bootchart tool"
+       help
+         systemd-bootchart is a tool, usually run at system startup,
+         that collects the CPU load, disk load, memory usage, as well
+         as per-process information from a running system. Collected
+         results are output as an SVG graph.
+
+         http://www.freedesktop.org/software/systemd/man/systemd-bootchart.html
+
 config BR2_PACKAGE_SYSTEMD_NETWORKD
        bool "enable network manager"
        help
index 124119fb272f66f6d569c5af1014678570fe745e..626638836f403fe79a9b38f901cd4f484160b43f 100644 (file)
@@ -143,6 +143,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-vconsole
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_BOOTCHART),y)
+SYSTEMD_CONF_OPTS += --enable-bootchart
+else
+SYSTEMD_CONF_OPTS += --disable-bootchart
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += --enable-networkd
 define SYSTEMD_INSTALL_RESOLVCONF_HOOK