atest: new package
authorFabio Estevam <festevam@gmail.com>
Sun, 9 Apr 2017 17:44:02 +0000 (14:44 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Apr 2017 20:47:25 +0000 (22:47 +0200)
Add support for atest application, which is useful for testing
alsa kernel drivers and detecting if playback/capture work correct
without artifacts, such as channel swap.

Signed-off-by: Fabio Estevam <festevam@gmail.com>
[Thomas: add missing Config.in comment.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/atest/Config.in [new file with mode: 0644]
package/atest/atest.hash [new file with mode: 0644]
package/atest/atest.mk [new file with mode: 0644]

index cdb24d09b7030b2c8b4448c800270613c69e3fbb..83cf6307fb8b2d3aeb09d241f1a3115d7034c6b0 100644 (file)
@@ -504,6 +504,7 @@ F:  configs/mx6sx_udoo_neo_defconfig
 F:     configs/mx6udoo_defconfig
 F:     configs/wandboard_defconfig
 F:     configs/warp7_defconfig
+F:     package/atest/
 F:     package/kmscube/
 
 N:     Fabio Porcedda <fabio.porcedda@gmail.com>
index 6a0f6f6e11065c2077f368a5e6e15f8abf370fe8..9a8158922774c7469b5661d11c32919357f81dce 100644 (file)
@@ -5,6 +5,7 @@ menu "Target packages"
 
 menu "Audio and video applications"
        source "package/alsa-utils/Config.in"
+       source "package/atest/Config.in"
        source "package/aumix/Config.in"
        source "package/bellagio/Config.in"
        source "package/dvblast/Config.in"
diff --git a/package/atest/Config.in b/package/atest/Config.in
new file mode 100644 (file)
index 0000000..1b357bb
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_ATEST
+       bool "atest"
+       depends on !BR2_TOOLCHAIN_USES_UCLIBC # uclibc lacks wordexp
+       depends on BR2_TOOLCHAIN_HAS_THREADS # alsa-lib
+       depends on !BR2_bfin # libev
+       select BR2_PACKAGE_ALSA_LIB
+       select BR2_PACKAGE_LIBEV
+       help
+         atest is a test software for checking ALSA Asoc drivers
+         concerning the proper frame generation and capture.
+
+         https://github.com/amouiche/atest
+
+comment "atest needs a glibc or musl toolchain w/ threads"
+       depends on !BR2_bfin
+       depends on BR2_TOOLCHAIN_USES_UCLIBC || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/atest/atest.hash b/package/atest/atest.hash
new file mode 100644 (file)
index 0000000..78e3ff8
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 91da5a6d4d0b0a8d4bae156a40e91a6dccf62863bfa7acae948efbbd2b4154ca  atest-895b0183a89c15f5e2305a6795bb1667753cd3f0.tar.gz
diff --git a/package/atest/atest.mk b/package/atest/atest.mk
new file mode 100644 (file)
index 0000000..2effda5
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# atest
+#
+################################################################################
+
+ATEST_VERSION = 895b0183a89c15f5e2305a6795bb1667753cd3f0
+ATEST_SITE = $(call github,amouiche,atest,$(ATEST_VERSION))
+ATEST_LICENSE = GPL-2.0+
+ATEST_LICENSE_FILES = COPYING
+ATEST_DEPENDENCIES = host-pkgconf libev alsa-lib
+# Fetched from Github, with no configure script
+ATEST_AUTORECONF = YES
+
+# Autoreconf requires an existing m4 directory
+define ATEST_PATCH_M4
+       mkdir -p $(@D)/m4
+endef
+ATEST_POST_PATCH_HOOKS += ATEST_PATCH_M4
+
+$(eval $(autotools-package))