netsnmp: Add option for using minimal internal SSL code
authorStefan Sørensen <stefan.sorensen@spectralink.com>
Tue, 17 Feb 2015 15:43:17 +0000 (16:43 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 19 Feb 2015 22:22:19 +0000 (23:22 +0100)
Add option for enabling a minimal internal copy of OpenSSL usable for USM
security. It will not enable the usage of SNMP over (D)TLS.

[Thomas: use 'else ifeq' to avoid having another nested ifeq ... endif
block.]

Signed-off-by: Stefan Sørensen <stefan.sorensen@spectralink.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/netsnmp/Config.in
package/netsnmp/netsnmp.mk

index 589f720fa0e9c43f99215ac620bd638e899495f7..47a53d7ead2f28df85f9955dafaf6ab3f9e9668b 100644 (file)
@@ -49,4 +49,11 @@ config BR2_PACKAGE_NETSNMP_ENABLE_DEBUGGING
          support, including the ability to log with DEBUGMSG(),
          DEBUGMSGTL() and companion macros.
 
+config BR2_PACKAGE_NETSNMP_OPENSSL_INTERNAL
+       bool "Enable minimal internal OpenSSL code"
+       depends on !BR2_PACKAGE_OPENSSL
+       help
+         Enable a minimal internal copy of OpenSSL usable for USM
+         security. It will not enable the usage of SNMP over (D)TLS.
+
 endif
index 58b52ef6f28027ed22f79d11ea975e8a262ab2a9..655552c455c1eb24700b71f7a29c655c8b0d9511 100644 (file)
@@ -54,6 +54,8 @@ ifeq ($(BR2_STATIC_LIBS),y)
        # openssl uses zlib, so we need to explicitly link with it when static
        NETSNMP_CONF_ENV += LIBS=-lz
 endif
+else ifeq ($(BR2_PACKAGE_NETSNMP_OPENSSL_INTERNAL),y)
+       NETSNMP_CONF_OPTS += --with-openssl=internal
 else
        NETSNMP_CONF_OPTS += --without-openssl
 endif