- simplify busybox version fiddling
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 20 Mar 2007 09:51:37 +0000 (09:51 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 20 Mar 2007 09:51:37 +0000 (09:51 -0000)
package/busybox/Config.in
package/busybox/busybox.mk

index 88d54fba2ea158ba4b1d8df9e1623fc9d572fa03..f04f34fb67402611de853b481e95f36d2430cd32 100644 (file)
@@ -12,7 +12,7 @@ config BR2_PACKAGE_BUSYBOX
 choice
        prompt "BusyBox Version"
        depends BR2_PACKAGE_BUSYBOX
-       default BR2_BUSYBOX_VERSION_1_2_2_1
+       default BR2_BUSYBOX_VERSION_1_4_2
        help
          Select the version of BusyBox you wish to use.
 
@@ -26,6 +26,7 @@ choice
 
        config BR2_BUSYBOX_VERSION_1_2_2_1
                bool "BusyBox 1.2.2.1"
+               depends on BR2_DEPRECATED
 
        config BR2_BUSYBOX_VERSION_1_4_0
                bool "BusyBox 1.4.0"
@@ -43,6 +44,14 @@ choice
 
 endchoice
 
+config BR2_BUSYBOX_VERSION
+       string
+       default "1.0.1"         if BR2_BUSYBOX_VERSION_1_0_1
+       default "1.1.3"         if BR2_BUSYBOX_VERSION_1_1_3
+       default "1.2.2.1"       if BR2_BUSYBOX_VERSION_1_2_2_1
+       default "1.4.0"         if BR2_BUSYBOX_VERSION_1_4_0
+       default "1.4.1"         if BR2_BUSYBOX_VERSION_1_4_1
+       default "1.4.2"         if BR2_BUSYBOX_VERSION_1_4_2
 
 
 config BR2_PACKAGE_BUSYBOX_INSTALL_SYMLINKS
index 1574e9a50b2adf950c8a3c169a5b5899d62f9c84..3d350a7943e106bf9f0835f51324a1aaa9dba6fe 100644 (file)
@@ -4,30 +4,6 @@
 #
 #############################################################
 
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_0_1)),y)
-BUSYBOX_VER:=1.01
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_1_3)),y)
-BUSYBOX_VER:=1.1.3
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_2_2_1)),y)
-BUSYBOX_VER:=1.2.2.1
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_4_0)),y)
-BUSYBOX_VER:=1.4.0
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_4_1)),y)
-BUSYBOX_VER:=1.4.1
-endif
-
-ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_4_2)),y)
-BUSYBOX_VER:=1.4.2
-endif
-
 
 ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
 # Be aware that this changes daily....
@@ -35,8 +11,8 @@ BUSYBOX_DIR:=$(BUILD_DIR)/busybox
 BUSYBOX_SOURCE:=busybox-snapshot.tar.bz2
 BUSYBOX_SITE:=http://www.busybox.net/downloads/snapshots
 else
-BUSYBOX_DIR:=$(BUILD_DIR)/busybox-$(BUSYBOX_VER)
-BUSYBOX_SOURCE:=busybox-$(BUSYBOX_VER).tar.bz2
+BUSYBOX_DIR:=$(BUILD_DIR)/busybox-$(BR2_BUSYBOX_VERSION)
+BUSYBOX_SOURCE:=busybox-$(BR2_BUSYBOX_VERSION).tar.bz2
 BUSYBOX_SITE:=http://www.busybox.net/downloads
 endif
 
@@ -62,7 +38,7 @@ endif
 ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
        toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox busybox.\*.patch
 else
-       toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox busybox-$(BUSYBOX_VER)-\*.patch
+       toolchain/patch-kernel.sh $(BUSYBOX_DIR) package/busybox busybox-$(BR2_BUSYBOX_VERSION)-\*.patch
 endif
        touch $@