- make sure to add board specific targets before the final generation of the filesyst...
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 28 Jan 2007 17:35:11 +0000 (17:35 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 28 Jan 2007 17:35:11 +0000 (17:35 -0000)
  Until now, we did created the fs and only after that built/installed grub et al

Makefile
target/Makefile.in

index b14750d36f305eb2c540f610fff2d3e07cf049d4..fb1716638eab3de83905488a4245c631a681058c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -67,7 +67,6 @@ include .config.cmd
 # in the .config file.
 include toolchain/*/*.mk
 include package/*/*.mk
-include target/*/*.mk
 
 # target stuff is last so it can override anything else
 include target/Makefile.in
index ec3955a1690224d26f834d1a68400305daeed8d9..c4de0770630b1ee2bdb9c603d6c538ff159daeae 100644 (file)
@@ -1,5 +1,8 @@
+# make sure to put everything that is board-specific before the tarroot targets
 include target/generic/Makefile.in
 include target/device/Makefile.in
 include target/x86/Makefile.in
 include target/arm/Makefile.in
 include target/powerpc/Makefile.in
+# and finally build the filesystems/tarballs
+include target/*/*.mk