Revert "i2c-tools: Add i2c-dev.h to staging directory for userspace i2c drivers."
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:14:26 +0000 (19:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:14:26 +0000 (19:14 +0100)
This reverts commit ff673f9a22b1467878f1a117f2c6198e9683d5c7, as the
modified i2c-dev.h from i2c-tools has some definitions that conflict
with the i2c.h from the kernel headers. This means that a userspace
program or library that includes both will fail to build, as is the
case with libsoc.

Fixes:

  http://autobuild.buildroot.org/results/1f4/1f451a338487a2a3c8a8f9b18540d41b90ee5aac/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/i2c-tools/i2c-tools.mk

index 450dba7b249bf26f69a6feb1b2ee0ec78f1118dc..c6a967d9878a76c5900c5144dea3e6212d680784 100644 (file)
@@ -9,7 +9,6 @@ I2C_TOOLS_SOURCE = i2c-tools-$(I2C_TOOLS_VERSION).tar.bz2
 I2C_TOOLS_SITE = http://dl.lm-sensors.org/i2c-tools/releases
 I2C_TOOLS_LICENSE = GPLv2+, GPLv2 (py-smbus)
 I2C_TOOLS_LICENSE_FILES = COPYING
-I2C_TOOLS_INSTALL_STAGING = YES
 
 define I2C_TOOLS_BUILD_CMDS
  $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
@@ -22,8 +21,4 @@ define I2C_TOOLS_INSTALL_TARGET_CMDS
        done
 endef
 
-define I2C_TOOLS_INSTALL_STAGING_CMDS
-       $(INSTALL) -D -m644 $(@D)/include/linux/i2c-dev.h $(STAGING_DIR)/usr/include/linux/
-endef
-
 $(eval $(generic-package))