pkg-rebar: remove redundant / in front of $($(PKG)_ERLANG_LIBDIR)
authorArnout Vandecappelle <arnout@mind.be>
Mon, 3 Jul 2017 12:44:55 +0000 (14:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 06:35:09 +0000 (08:35 +0200)
Sometimes $(1)/$($(PKG)_ERLANG_LIBDIR) is used, sometimes
$(1)$($(PKG)_ERLANG_LIBDIR). Make this consistent, with /. Therefore,
remove the leading / from $($(PKG)_ERLANG_LIBDIR).

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-rebar.mk

index 7605a64aded456e9842ec685fa17536e48298234..cc6b775ae5674dec248e591f438870fa505575fe 100644 (file)
@@ -44,7 +44,7 @@ REBAR_TARGET_DEPS_ENV = \
 # Install an Erlang application from $(@D).
 #
 # i.e., define a recipe that installs the "bin ebin priv $(2)" directories
-# from $(@D) to $(1)$($(PKG)_ERLANG_LIBDIR).
+# from $(@D) to $(1)/$($(PKG)_ERLANG_LIBDIR).
 #
 #  argument 1 should typically be $(HOST_DIR), $(TARGET_DIR),
 #            or $(STAGING_DIR).
@@ -59,7 +59,7 @@ define install-erlang-directories
        $(INSTALL) -d $(1)/$($(PKG)_ERLANG_LIBDIR)
        for dir in bin ebin priv $(2); do                               \
                if test -d $(@D)/$$dir; then                            \
-                       cp -r $(@D)/$$dir $(1)$($(PKG)_ERLANG_LIBDIR);  \
+                       cp -r $(@D)/$$dir $(1)/$($(PKG)_ERLANG_LIBDIR); \
                fi;                                                     \
        done
 endef
@@ -122,7 +122,7 @@ $(2)_ERLANG_APP = $(subst -,_,$(patsubst erlang-%,%,$(patsubst host-%,%,$(1))))
 # for host packages, or $(STAGING_DIR) for target packages.
 #
 $(2)_ERLANG_LIBDIR = \
-       /usr/lib/erlang/lib/$$($$(PKG)_ERLANG_APP)-$$($$(PKG)_VERSION)
+       usr/lib/erlang/lib/$$($$(PKG)_ERLANG_APP)-$$($$(PKG)_VERSION)
 
 # If a host package, inherit <pkg>_USE_BUNDLED_REBAR from the target
 # package, if not explicitly defined. Otherwise, default to NO.