package/grpc: bump version to 1.39.0
authorMichael Nosthoff <buildroot@heine.tech>
Wed, 4 Aug 2021 11:45:37 +0000 (13:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 4 Aug 2021 20:01:54 +0000 (22:01 +0200)
 * drop CMakeLists.txt patch applied upstream.
 * Update patch for wrap_memcpy.cc to match changed target file.
 * update patch numbering.

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/grpc/0001-CMakeLists.txt-fix-cross-compilation-with-gRPC_BUILD.patch [deleted file]
package/grpc/0001-Properly-detect-the-availability-of-pthread_setname_.patch [new file with mode: 0644]
package/grpc/0002-Properly-detect-the-availability-of-pthread_setname_.patch [deleted file]
package/grpc/0002-wrap_memcpy.cc-add-GPR_DISABLE_WRAPPED_MEMCPY.patch [new file with mode: 0644]
package/grpc/0003-wrap_memcpy.cc-add-GPR_DISABLE_WRAPPED_MEMCPY.patch [deleted file]
package/grpc/grpc.hash
package/grpc/grpc.mk

diff --git a/package/grpc/0001-CMakeLists.txt-fix-cross-compilation-with-gRPC_BUILD.patch b/package/grpc/0001-CMakeLists.txt-fix-cross-compilation-with-gRPC_BUILD.patch
deleted file mode 100644 (file)
index 553be8c..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From 268815d74ea34856c686dce9e9c23106b51f2782 Mon Sep 17 00:00:00 2001
-From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
-Date: Tue, 2 Feb 2021 21:46:29 +0100
-Subject: [PATCH] CMakeLists.txt: fix cross-compilation with
- gRPC_BUILD_GRPC_CPP_PLUGIN=OFF
-
-When cross-compiling gRPC, a native version of 'grpc_cpp_plugin' is searched
-in the environment. For most use cases, a cross version of this file is not
-needed.
-
-However, when cross-building with -DgRPC_BUILD_GRPC_CPP_PLUGIN=OFF, there
-are some build errors, for example:
-
-make[3]: *** No rule to make target 'grpc_cpp_plugin', needed by 'gens/src/proto/grpc/reflection/v1alpha/reflection.grpc.pb.cc'.  Stop.
-
-This is because there is still a hard dependency on 'grpc_cpp_plugin' for
-these targets, not taking into account the cross-compilation case.
-
-Fix by depending on the variable gRPC_CPP_PLUGIN, which is set correctly for
-either cross or native case.
-
-Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 6bdae22083..08aea609f7 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -317,7 +317,7 @@ function(protobuf_generate_grpc_cpp)
-            --plugin=protoc-gen-grpc=${_gRPC_CPP_PLUGIN}
-            ${_protobuf_include_path}
-            ${REL_FIL}
--      DEPENDS ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} grpc_cpp_plugin
-+      DEPENDS ${ABS_FIL} ${_gRPC_PROTOBUF_PROTOC} ${_gRPC_CPP_PLUGIN}
-       WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-       COMMENT "Running gRPC C++ protocol buffer compiler on ${FIL}"
-       VERBATIM)
--- 
-2.26.2
-
diff --git a/package/grpc/0001-Properly-detect-the-availability-of-pthread_setname_.patch b/package/grpc/0001-Properly-detect-the-availability-of-pthread_setname_.patch
new file mode 100644 (file)
index 0000000..32493ac
--- /dev/null
@@ -0,0 +1,51 @@
+From 0dfb289a3b362b082ac3608d887e42f09dadc0d2 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
+Date: Mon, 31 Dec 2018 16:22:07 +0100
+Subject: [PATCH] Properly detect the availability of pthread_setname_np()
+
+This commit adds a CMake check for the availability of
+pthread_setname_np(), and only uses it on Linux when available.
+
+Indeed, some C libraries, such as uClibc, do not provide this
+non-POSIX function in all cases.
+
+Upstream: https://github.com/grpc/grpc/pull/17610
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
+---
+ CMakeLists.txt                            | 6 ++++++
+ include/grpc/impl/codegen/port_platform.h | 2 ++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 45c2fcb..0b2be4f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -208,6 +208,12 @@ if (NOT DEFINED CMAKE_POSITION_INDEPENDENT_CODE)
+ endif()
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
++include(CheckSymbolExists)
++check_symbol_exists(pthread_setname_np pthread.h HAVE_PTHREAD_SETNAME_NP)
++if (HAVE_PTHREAD_SETNAME_NP)
++  add_definitions(-DHAVE_PTHREAD_SETNAME_NP)
++endif ()
++
+ if(MSVC)
+   include(cmake/msvc_static_runtime.cmake)
+   add_definitions(-D_WIN32_WINNT=0x600 -D_SCL_SECURE_NO_WARNINGS -D_CRT_SECURE_NO_WARNINGS -D_WINSOCK_DEPRECATED_NO_WARNINGS)
+diff --git a/include/grpc/impl/codegen/port_platform.h b/include/grpc/impl/codegen/port_platform.h
+index 4f213ff..55ecd9d 100644
+--- a/include/grpc/impl/codegen/port_platform.h
++++ b/include/grpc/impl/codegen/port_platform.h
+@@ -168,7 +168,9 @@
+ #endif /* _LP64 */
+ #ifdef __GLIBC__
+ #define GPR_POSIX_CRASH_HANDLER 1
++#if defined(HAVE_PTHREAD_SETNAME_NP)
+ #define GPR_LINUX_PTHREAD_NAME 1
++#endif /* HAVE_PTHREAD_SETNAME_NP */
+ #include <linux/version.h>
+ #else /* musl libc */
+ #define GPR_MUSL_LIBC_COMPAT 1
+-- 
+2.26.63
diff --git a/package/grpc/0002-Properly-detect-the-availability-of-pthread_setname_.patch b/package/grpc/0002-Properly-detect-the-availability-of-pthread_setname_.patch
deleted file mode 100644 (file)
index 32493ac..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-From 0dfb289a3b362b082ac3608d887e42f09dadc0d2 Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-Date: Mon, 31 Dec 2018 16:22:07 +0100
-Subject: [PATCH] Properly detect the availability of pthread_setname_np()
-
-This commit adds a CMake check for the availability of
-pthread_setname_np(), and only uses it on Linux when available.
-
-Indeed, some C libraries, such as uClibc, do not provide this
-non-POSIX function in all cases.
-
-Upstream: https://github.com/grpc/grpc/pull/17610
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
----
- CMakeLists.txt                            | 6 ++++++
- include/grpc/impl/codegen/port_platform.h | 2 ++
- 2 files changed, 8 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 45c2fcb..0b2be4f 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -208,6 +208,12 @@ if (NOT DEFINED CMAKE_POSITION_INDEPENDENT_CODE)
- endif()
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
-+include(CheckSymbolExists)
-+check_symbol_exists(pthread_setname_np pthread.h HAVE_PTHREAD_SETNAME_NP)
-+if (HAVE_PTHREAD_SETNAME_NP)
-+  add_definitions(-DHAVE_PTHREAD_SETNAME_NP)
-+endif ()
-+
- if(MSVC)
-   include(cmake/msvc_static_runtime.cmake)
-   add_definitions(-D_WIN32_WINNT=0x600 -D_SCL_SECURE_NO_WARNINGS -D_CRT_SECURE_NO_WARNINGS -D_WINSOCK_DEPRECATED_NO_WARNINGS)
-diff --git a/include/grpc/impl/codegen/port_platform.h b/include/grpc/impl/codegen/port_platform.h
-index 4f213ff..55ecd9d 100644
---- a/include/grpc/impl/codegen/port_platform.h
-+++ b/include/grpc/impl/codegen/port_platform.h
-@@ -168,7 +168,9 @@
- #endif /* _LP64 */
- #ifdef __GLIBC__
- #define GPR_POSIX_CRASH_HANDLER 1
-+#if defined(HAVE_PTHREAD_SETNAME_NP)
- #define GPR_LINUX_PTHREAD_NAME 1
-+#endif /* HAVE_PTHREAD_SETNAME_NP */
- #include <linux/version.h>
- #else /* musl libc */
- #define GPR_MUSL_LIBC_COMPAT 1
--- 
-2.26.63
diff --git a/package/grpc/0002-wrap_memcpy.cc-add-GPR_DISABLE_WRAPPED_MEMCPY.patch b/package/grpc/0002-wrap_memcpy.cc-add-GPR_DISABLE_WRAPPED_MEMCPY.patch
new file mode 100644 (file)
index 0000000..aac92ba
--- /dev/null
@@ -0,0 +1,34 @@
+From be030314805137cd63b46ea6eaa702b608669910 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sun, 2 Jun 2019 17:45:47 +0200
+Subject: [PATCH] wrap_memcpy.cc: add GPR_DISABLE_WRAPPED_MEMCPY
+
+Add GPR_DISABLE_WRAPPED_MEMCPY to allow the user to disable wrapped
+memcpy. This will fix build on x86_64 on musl/uclibc without changing
+the cpu behavior.
+
+Fixes:
+ - http://autobuild.buildroot.org/results/20d6f2489a4e291a53bd514da66105eb607e1014
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: https://github.com/grpc/grpc/pull/19207]
+---
+ src/core/lib/gpr/wrap_memcpy.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/core/lib/gpr/wrap_memcpy.cc b/src/core/lib/gpr/wrap_memcpy.cc
+index 9b8608e056..38b76acf95 100644
+--- a/src/core/lib/gpr/wrap_memcpy.cc
++++ b/src/core/lib/gpr/wrap_memcpy.cc
+@@ -29,7 +29,7 @@
+ extern "C" {
+ #ifdef __linux__
+ #if defined(__x86_64__) && !defined(GPR_MUSL_LIBC_COMPAT) && \
+-    !defined(__ANDROID__)
++    !defined(__ANDROID__) && !defined(GPR_DISABLE_WRAPPED_MEMCPY)
+ __asm__(".symver memcpy,memcpy@GLIBC_2.2.5");
+ void* __wrap_memcpy(void* destination, const void* source, size_t num) {
+   return memcpy(destination, source, num);
+-- 
+2.20.1
+
diff --git a/package/grpc/0003-wrap_memcpy.cc-add-GPR_DISABLE_WRAPPED_MEMCPY.patch b/package/grpc/0003-wrap_memcpy.cc-add-GPR_DISABLE_WRAPPED_MEMCPY.patch
deleted file mode 100644 (file)
index ad64804..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From be030314805137cd63b46ea6eaa702b608669910 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sun, 2 Jun 2019 17:45:47 +0200
-Subject: [PATCH] wrap_memcpy.cc: add GPR_DISABLE_WRAPPED_MEMCPY
-
-Add GPR_DISABLE_WRAPPED_MEMCPY to allow the user to disable wrapped
-memcpy. This will fix build on x86_64 on musl/uclibc without changing
-the cpu behavior.
-
-Fixes:
- - http://autobuild.buildroot.org/results/20d6f2489a4e291a53bd514da66105eb607e1014
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/grpc/grpc/pull/19207]
----
- src/core/lib/gpr/wrap_memcpy.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/core/lib/gpr/wrap_memcpy.cc b/src/core/lib/gpr/wrap_memcpy.cc
-index 9b8608e056..38b76acf95 100644
---- a/src/core/lib/gpr/wrap_memcpy.cc
-+++ b/src/core/lib/gpr/wrap_memcpy.cc
-@@ -28,7 +28,7 @@
- extern "C" {
- #ifdef __linux__
--#if defined(__x86_64__) && !defined(GPR_MUSL_LIBC_COMPAT)
-+#if defined(__x86_64__) && !defined(GPR_MUSL_LIBC_COMPAT) && !defined(GPR_DISABLE_WRAPPED_MEMCPY)
- __asm__(".symver memcpy,memcpy@GLIBC_2.2.5");
- void* __wrap_memcpy(void* destination, const void* source, size_t num) {
-   return memcpy(destination, source, num);
--- 
-2.20.1
-
index 01dc9ca2402f6f02486a3c69319f97f11fd035ac..f1153469e7318201863121e88bc896574482483d 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  f60e5b112913bf776a22c16a3053cc02cf55e60bf27a959fd54d7aaf8e2da6e8  grpc-1.38.1.tar.gz
+sha256  b16992aa1c949c10d5d5ce2a62f9d99fa7de77da2943e643fb66dcaf075826d6  grpc-1.39.0.tar.gz
 sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE
index f3975316aeb602500fd9b293f89b65497a99e2e4..1426158d82bf64f1492bd8983350f436593535cb 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GRPC_VERSION = 1.38.1
+GRPC_VERSION = 1.39.0
 GRPC_SITE = $(call github,grpc,grpc,v$(GRPC_VERSION))
 GRPC_LICENSE = Apache-2.0
 GRPC_LICENSE_FILES = LICENSE