qt5serialbus: install examples to target
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Tue, 12 Jun 2018 12:32:04 +0000 (08:32 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 12:35:14 +0000 (14:35 +0200)
When BR2_PACKAGE_QT5BASE_EXAMPLES is set, the examples for this module
are installed in the staging directory but they are not shipped to the
target.

This commit copies the examples `serialbus' from the staging directory
to the target.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5serialbus/qt5serialbus.mk

index c9a2139556ba7674bce3564d11d854b2d9b786ff..6de9f9b7d3b38608a8ae58df559ff7419485d0d5 100644 (file)
@@ -36,8 +36,15 @@ define QT5SERIALBUS_INSTALL_TARGET_LIBS
 endef
 endif
 
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5SERIALBUS_INSTALL_TARGET_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/serialbus $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
+
 define QT5SERIALBUS_INSTALL_TARGET_CMDS
        $(QT5SERIALBUS_INSTALL_TARGET_LIBS)
+       $(QT5SERIALBUS_INSTALL_TARGET_EXAMPLES)
        $(INSTALL) -m 0755 -D $(@D)/bin/canbusutil \
                $(TARGET_DIR)/usr/bin/canbusutil
 endef