Fix Qtopia build issues
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 11 Nov 2008 18:35:43 +0000 (18:35 -0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 11 Nov 2008 18:35:43 +0000 (18:35 -0000)
This patch fixes two Qtopia build issues, encountered while trying to
use system implementation of zlib, freetype, jpeg and libpng :

 * The build process doesn't look in $(STAGING_DIR)/usr/include for
   includes and $(STAGING_DIR)/usr/lib. Same problem as the patch
   currently floating around adding LDFLAGS to TARGET_CONFIGURE_OPTS,
   but as Qtopia doesn't use TARGET_CONFIGURE_OPTS, we need a specific
   fix here. So we use the -I and -L options of Qtopia's configure
   script.

 * The build process doesn't use pkg-config to get the header path for
   Freetype headers (located in $(STAGING_DIR)/usr/include/freetype2
   and not directly in $(STAGING_DIR)/usr/include/). There was already
   a fix for this, consisting in adding $(FREETYPE_DIR)/include to the
   -I path of Qtopia's configure. This patch modifies this fix to use
   $(STAGING_DIR)/usr/include/freetype2 instead, which looks more
   coherent with how all the packages are built (using $(STAGING_DIR)
   as the reference to get headers and libraries).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qtopia4/qtopia4.mk

index 8b0415f25aa45c3e8aa20ef455c7b5c547307aad..ef405285bd1a42dde2a2fbde4bccb4ee93c69ee8 100644 (file)
@@ -212,7 +212,7 @@ QTOPIA4_CONFIGURE+= -qt-freetype
 else
 ifeq ($(BR2_PACKAGE_QTOPIA4_SYSTEMFREETYPE),y)
 QTOPIA4_CONFIGURE+= -system-freetype
-QTOPIA4_CONFIGURE+= -I $(FREETYPE_DIR)/include
+QTOPIA4_CONFIGURE+= -I $(STAGING_DIR)/usr/include/freetype2/
 QTOPIA4_DEP_LIBS+=freetype
 else
 QTOPIA4_CONFIGURE+= -no-freetype
@@ -342,6 +342,8 @@ endif
                -no-rpath \
                -nomake examples \
                -nomake demos \
+               -I $(STAGING_DIR)/usr/include \
+               -L $(STAGING_DIR)/usr/lib \
        )
        touch $@