gst1-plugins-bad: remove mpg123 plugin option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 3 May 2016 19:44:14 +0000 (16:44 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 5 May 2016 06:29:04 +0000 (08:29 +0200)
The plugin was moved from -bad to -ugly so remove the option.
Support in -ugly was added via 30cde9a3.
Add legacy entry to notify users of this, however we can't automatically
select the ugly variant since ugly might be disabled.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 9f694f87e43f96c548bea0129cf882d5a0b13f7e..9901cf6f39daef18f97d2de36e7de23e0ecc31af 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.05"
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPG123
+       bool "gst1-plugins-bad mpg123 plugin moved to ugly"
+       select BR2_LEGACY
+       help
+         The mpg123 plugin has been moved from gst1-plugins-bad to
+         gst1-plugins-ugly.
+
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC
        bool "PowerPC Sourcery toolchain has been removed"
        select BR2_LEGACY
index a9667afa343ee56309b59af87d0f4c8fa8d8cc34..16bb36d1f93d9c51c7b053c8d56105e2b2a1e5ce 100644 (file)
@@ -553,13 +553,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPEG2ENC
        help
          High-quality MPEG-1/2 video encoder
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPG123
-       bool "mpg123"
-       select BR2_PACKAGE_MPG123
-       depends on BR2_USE_MMU # mpg123
-       help
-         mp3 decoding based on the mpg123 library
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MUSEPACK
        bool "musepack"
        select BR2_PACKAGE_MUSEPACK
index a92c4a6515a649284fcde19675c77039063c1583..80bdee8b36d7272918c44f6a541aad107bf5154d 100644 (file)
@@ -692,13 +692,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-mpeg2enc
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPG123),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-mpg123
-GST1_PLUGINS_BAD_DEPENDENCIES += mpg123
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-mpg123
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MUSEPACK),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-musepack
 GST1_PLUGINS_BAD_DEPENDENCIES += musepack