package/flare-engine: new package
authorRomain Naour <romain.naour@gmail.com>
Mon, 19 Mar 2018 21:19:02 +0000 (22:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 9 Apr 2018 19:41:33 +0000 (21:41 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/flare-engine/Config.in [new file with mode: 0644]
package/flare-engine/flare-engine.hash [new file with mode: 0644]
package/flare-engine/flare-engine.mk [new file with mode: 0644]

index 8a6793b5a958b41dae54b79e7a74a2e077c9cb89..3353ee0f89ce4e2839827cfccc2cd84345d88975 100644 (file)
@@ -1591,6 +1591,7 @@ F:        package/bullet/
 F:     package/efl/
 F:     package/enlightenment/
 F:     package/expedite/
+F:     package/flare-engine/
 F:     package/irrlicht/
 F:     package/liblinear/
 F:     package/lensfun/
index 5e798a4f14a65f4bb730b1e6e5fb6f973f5347d7..71c186613ed45d852af53f81f8cf50abb317a566 100644 (file)
@@ -234,6 +234,7 @@ endmenu
 menu "Games"
        source "package/chocolate-doom/Config.in"
        source "package/doom-wad/Config.in"
+       source "package/flare-engine/Config.in"
        source "package/gnuchess/Config.in"
        source "package/lbreakout2/Config.in"
        source "package/ltris/Config.in"
diff --git a/package/flare-engine/Config.in b/package/flare-engine/Config.in
new file mode 100644 (file)
index 0000000..cdcb018
--- /dev/null
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_FLARE_ENGINE
+       bool "flare-engine"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on !BR2_STATIC_LIBS # SDL2
+       select BR2_PACKAGE_SDL2
+       select BR2_PACKAGE_SDL2_IMAGE
+       select BR2_PACKAGE_SDL2_MIXER
+       select BR2_PACKAGE_SDL2_TTF
+       help
+         Flare (Free Libre Action Roleplaying Engine) is a simple game
+         engine built to handle a very specific kind of game:
+         single-player 2D action RPGs.
+         Flare is not a reimplementation of an existing game or engine.
+         It is a tribute to and exploration of the action RPG genre.
+
+         http://flarerpg.org
+
+comment "flare-engine needs a toolchain w/ C++, dynamic library"
+       depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS
diff --git a/package/flare-engine/flare-engine.hash b/package/flare-engine/flare-engine.hash
new file mode 100644 (file)
index 0000000..8c6fc3a
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256  4bbd4674513b643be6294188904665c53f0ef2912e803212c05e8fd22a44d74d  flare-engine-v1.0.tar.gz
+sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  COPYING
diff --git a/package/flare-engine/flare-engine.mk b/package/flare-engine/flare-engine.mk
new file mode 100644 (file)
index 0000000..394ddcf
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# flare-engine
+#
+################################################################################
+
+FLARE_ENGINE_VERSION = v1.0
+FLARE_ENGINE_SITE =  $(call github,clintbellanger,flare-engine,$(FLARE_ENGINE_VERSION))
+FLARE_ENGINE_LICENSE = GPL-3.0
+FLARE_ENGINE_LICENSE_FILES = COPYING
+
+FLARE_ENGINE_DEPENDENCIES += sdl2 sdl2_image sdl2_mixer sdl2_ttf
+
+# Don't use /usr/games and /usr/share/games
+FLARE_ENGINE_CONF_OPTS += -DBINDIR=bin -DDATADIR=share/flare
+
+$(eval $(cmake-package))