uclibc: use $(MAKE) iso $(MAKE1) for menuconfig target
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Thu, 24 Jul 2014 17:49:29 +0000 (19:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Jul 2014 21:46:39 +0000 (23:46 +0200)
There is no real reason to run uclibc-menuconfig in non-parallel mode,
even though one can neither expect performance benefits from a parallel
menuconfig.
Nevertheless, $(MAKE) is the default, so this patch removes the unnecessary
non-default $(MAKE1) usage for uclibc-menuconfig.

This is a simplification introduced in preparation of the kconfig-package
infrastructure.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/uclibc.mk

index 4bc5ae1223b08b78e136f4c2f9963533a1099fb1..e7749afc40c4c8b7950fc41e10c7e2a0cedc7c00 100644 (file)
@@ -543,7 +543,7 @@ $(UCLIBC_DIR)/.stamp_config_fixup_done: $(UCLIBC_DIR)/.config
 $(UCLIBC_TARGET_CONFIGURE): $(UCLIBC_DIR)/.stamp_config_fixup_done
 
 uclibc-menuconfig: $(UCLIBC_DIR)/.config
-       $(MAKE1) -C $(UCLIBC_DIR) \
+       $(MAKE) -C $(UCLIBC_DIR) \
                $(UCLIBC_MAKE_FLAGS) \
                PREFIX=$(STAGING_DIR) \
                DEVEL_PREFIX=/usr/ \