ncurses: better handling for shared/static library
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 11 Dec 2014 22:50:10 +0000 (23:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 11 Dec 2014 23:09:32 +0000 (00:09 +0100)
Now that we have clear options for the three cases of shared only,
static only and shared+static, let's use them in ncurses to pass the
appropriate --{with,without}-{shared,normal} options.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/ncurses/ncurses.mk

index 645c25c1bc3fcbfbad030f5f79d34e2f68f1d000..f54f379ba181f53e6ec8f68c104fed156c6f3c60 100644 (file)
@@ -15,7 +15,6 @@ NCURSES_LICENSE_FILES = README
 NCURSES_CONFIG_SCRIPTS = ncurses$(NCURSES_LIB_SUFFIX)5-config
 
 NCURSES_CONF_OPTS = \
-       $(if $(BR2_STATIC_LIBS),--without-shared,--with-shared) \
        --without-cxx \
        --without-cxx-binding \
        --without-ada \
@@ -36,6 +35,14 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
        NCURSES_DEPENDENCIES += busybox
 endif
 
+ifeq ($(BR2_STATIC_LIBS),y)
+NCURSES_CONF_OPTS += --without-shared --with-normal
+else ifeq ($(BR2_SHARED_LIBS),y)
+NCURSES_CONF_OPTS += --with-shared --without-normal
+else ifeq ($(BR2_SHARED_STATIC_LIBS),y)
+NCURSES_CONF_OPTS += --with-shared --with-normal
+endif
+
 ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
 NCURSES_CONF_OPTS += --enable-widec
 NCURSES_LIB_SUFFIX = w