i2c-tools: ensure binaries are installed in the right place
authorLionel Landwerlin <llandwerlin@gmail.com>
Thu, 9 Dec 2010 09:55:03 +0000 (10:55 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 Dec 2010 23:17:14 +0000 (00:17 +0100)
And remove unneeded explicit stripping of target binaries

[Peter: use install -D]
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/i2c-tools/i2c-tools.mk

diff --git a/CHANGES b/CHANGES
index 2c24609aee522144b6dab1095c9d713592345c4f..11c2becb1bfb8ca0af47997796c110043c39d4da 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -4,7 +4,7 @@
        compilation, and cache is stored in ~/.buildroot-ccache.
 
        Updated/fixed packages: busybox, dbus, cloop, gdk-pixbuf,
-       hostapd, libconfig, m4, openssh, openssl, qt, usbutils, xz,
+       hostapd, i2c-tools, libconfig, m4, openssh, openssl, qt, usbutils, xz,
        zlib
 
        New packages: dhrystone, lsuio, rsh-redone, whetstone
index d419524fe2cc68534abb0e5c86c83b9beac6f2a6..58dde05a6e31e909f4c262ae25bab4ec3118e9e3 100644 (file)
@@ -14,8 +14,7 @@ endef
 define I2C_TOOLS_INSTALL_TARGET_CMDS
        for i in i2cdump i2cget i2cset i2cdetect; \
        do \
-               $(INSTALL) -m 755 $(@D)/tools/$$i $(TARGET_DIR)/usr/bin/$$i; \
-               $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/bin/$$i; \
+               $(INSTALL) -m 755 -D $(@D)/tools/$$i $(TARGET_DIR)/usr/bin/$$i; \
        done
 endef