New package: acl
authorYegor Yefremov <yegor_sub1@visionsystems.de>
Wed, 13 Jul 2011 09:13:59 +0000 (11:13 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 13 Jul 2011 13:02:54 +0000 (15:02 +0200)
POSIX Access Control Lists, which are used to define more
fine-grained discretionary access rights for files and
directories.

[Peter: needs largefile]
Signed-off-by: Heiko Zuerker <smiley73@users.sourceforge.net>
Signed-off-by: Daniel Mack <zonque@gmail.com>
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/acl/Config.in [new file with mode: 0644]
package/acl/acl.mk [new file with mode: 0644]

index 069d8bb0b12588b5358e14e07579dc3248d65adf..2fa9ff5ae51c6be907d8ecb9aca3e07574cb9df5 100644 (file)
@@ -495,6 +495,7 @@ source "package/xmlstarlet/Config.in"
 endmenu
 
 menu "System tools"
+source "package/acl/Config.in"
 source "package/attr/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/bootutils/Config.in"
diff --git a/package/acl/Config.in b/package/acl/Config.in
new file mode 100644 (file)
index 0000000..f3d10d5
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_ACL
+       bool "acl"
+       select BR2_PACKAGE_ATTR
+       depends on BR2_LARGEFILE
+       help
+         POSIX Access Control Lists, which are used to define more
+         fine-grained discretionary access rights for files and
+         directories.
+         This package also provides libacl.
+
+         http://savannah.nongnu.org/projects/acl
+
+comment "acl requires a toolchain with LARGEFILE support"
+       depends on !BR2_LARGEFILE
diff --git a/package/acl/acl.mk b/package/acl/acl.mk
new file mode 100644 (file)
index 0000000..11768f6
--- /dev/null
@@ -0,0 +1,28 @@
+#############################################################
+#
+# acl
+#
+#############################################################
+
+ACL_VERSION = 2.2.51
+ACL_SOURCE = acl-$(ACL_VERSION).src.tar.gz
+ACL_SITE = http://download.savannah.gnu.org/releases/acl
+ACL_INSTALL_STAGING = YES
+ACL_DEPENDENCIES = attr
+ACL_CONF_OPT = --enable-gettext=no
+
+# While the configuration system uses autoconf, the Makefiles are
+# hand-written and do not use automake. Therefore, we have to hack
+# around their deficiencies by passing installation paths.
+ACL_INSTALL_STAGING_OPT =                      \
+       prefix=$(STAGING_DIR)/usr               \
+       exec_prefix=$(STAGING_DIR)/usr          \
+       PKG_DEVLIB_DIR=$(STAGING_DIR)/usr/lib   \
+       install-dev install-lib
+
+ACL_INSTALL_TARGET_OPT =                       \
+       prefix=$(TARGET_DIR)/usr                \
+       exec_prefix=$(TARGET_DIR)/usr           \
+       install install-lib
+
+$(eval $(call AUTOTARGETS,package,acl))